绝对量柱副图-精品通达信指标公式源码分享

通达信免费指标 07-10 阅读:22 评论:0

image.png

万手:VOL/10000,LINETHICK0;

AA:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);

预测:AA/10000;

BB:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

主动买:=IF(CLOSE>OPEN,BB*(HIGH-LOW),IF(CLOSE<OPEN,BB*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));

主买:=主动买/10000,COLORRED;

主动卖:=IF(CLOSE>OPEN,0-BB*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-BB*(HIGH-LOW),0-VOL/2));

主卖:=-主动卖/10000,COLORGREEN;

总额:=主买+主卖;

主买占比%:主买/总额*100,COLORMAGENTA;

V总:=主动买-主动卖;

买卖比:主动买/(-主动卖);

VE:=V总/REF(V总,1);

倍量:VE>2;

倍缩:VE<=0.5;

差额:=(主动买+主动卖)/10000;

MA5:MA(V,5)COLORWHITE;

MA10:=MA(V,10)COLORRED;

MA120:MA(V,60)COLORYELLOW;

持币:IF(SAR(10,2,20)>=H,SAR(10,2,20),DRAWNULL);

DRAWICON(持币>0,持币,2 );   

持股:IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL);

DRAWICON(持股>0,持股,1 );

STICKLINE(主动买,0,主动买,2.0,0),COLORMAGENTA;

STICKLINE(买卖比>1,主动买,V总,2.0,0),COLORYELLOW;

STICKLINE(买卖比<=1,主动买,V总,2.0,0),COLORBLUE;

STICKLINE(VE>2,0,V总/3,2.0,0),COLORRED;

STICKLINE(VE<=0.5,0,V总/3,2.0,0),COLORGREEN;

VAR3:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

VAR5:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;

VAR6:=(VAR3+VAR4+VAR5)/3;

VAR7:=EMA(VAR6,5);

K:EMA(VAR7,5)*2, ,COLORFF00FF;

D:EMA(K,5), , COLORWHITE;

J:K*3-D*2, ,COLORYELLOW;

DRAWTEXT_FIX(1,0.08,0.05,0,'【粉+黄做多】【粉+蓝做空】【粉色做多】【蓝色做空】【黄色做多】【红色倍量】【绿色缩量】')COLOR00FFFF;


版权声明

本文版权归掌上指标所有。
未经许可,不得转载,转载请注明出处!

服务热线

18020657357

微信客服

微信客服