【通达信源码分享】主力状态指标源码附图 让你不失时机进场

通达信免费指标 08-25 阅读:6723 评论:0

公式源码:


 


ZLCM:=EMA(WINNER(CLOSE)*7,3);{主力筹码估算}

SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*8,3);{散户筹码估算}

ZSHTL:=SHCM/(ZLCM+SHCM)*10;{散户套牢筹码比率}

ZCMZL:=MA(ZLCM+SHCM,13);{市场筹码总量}

ZZNTS:=BARSLAST(ZSHTL<9 AND REF(ZSHTL,1)>9);{走牛天数}

ZSHJJ:=EMA(ZSHTL,89);

中线强势:IF(ZLCM/(ZLCM+SHCM)*20-4>0,2*(ZLCM/(ZLCM+SHCM)*20-4),0),COLORRED,LINETHICK2;{主力控盘筹码比率}

ZZLJJ:=EMA(中线强势,89);

ZJLRQD:=IF(INTPART(中线强势-ZZLJJ)>0,INTPART(中线强势-ZZLJJ)-1,0);{资金流入强度}

短线强势:IF(ZJLRQD>0 AND C>REF(C,1),ZJLRQD*1.5,0),LINETHICK3,COLORMAGENTA;

短线强势减昨日:短线强势-REF(短线强势,1),LINETHICK0;

SH8:=EMA(ZSHTL,8);

DKB:=IF(中线强势-REF(中线强势,1)>ZSHTL-REF(ZSHTL,1),1,0);

{主力控盘筹码}

STICKLINE(C>0,中线强势,0,3,0),COLORRED;

{筑底散兵坑}

STICKLINE(ZSHTL>=90,中线强势,0,3,0),COLOR66FFCC;

散户套牢系数:=INTPART(ZSHTL);

中线控盘:INTPART(中线强势)/5,COLORYELLOW,LINETHICK2;

短线超跌:IF(-ZJLRQD>0,ZJLRQD,0),LINETHICK2,COLORBLUE;

STICKLINE(短线超跌,ZJLRQD,0,3,0),COLORBLUE;

市场筹码总量:=INTPART(ZCMZL); 

STICKLINE(短线强势,ZJLRQD*1.5,0,3,0),COLORMAGENTA;

STICKLINE(中线控盘,中线控盘,0,3,0),COLORYELLOW;

30-1G210160259.png

版权声明

本文版权归掌上指标所有。
未经许可,不得转载,转载请注明出处!

服务热线

18020657357

微信客服

微信客服