神剑出鞘-精品通达信指标公式源码分享

通达信免费指标 06-11 阅读:27 评论:0

image.png

VAR100:=IF(DATE<=1280831,1,0);


CSS:=((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100)*VAR100;


YJDD:=(EMA(CSS,3)-50)*2* VAR100;


强弱:(YJDD+100)/2* VAR100,COLORBLUE;


80*VAR100,COLORRED,POINTDOT,LINETHICK3;


20*VAR100,COLORRED,POINTDOT,LINETHICK3;


100*VAR100,COLORBLUE;


T1:=(INDEXC-MA(INDEXC,58))/MA(INDEXC,58)<-0.152;


T2:=(C-EMA(C,58))/EMA(C,58)<-0.19;


买1:=T2 AND T1;


T3:=IF(DATE<=1280831,1,0);


T4:=(C-MA(C,2))/MA(C,2)*100*T3;


T5:=INDEXC*T3;


T6:=MA(T5,13)*T3;


T7:=T6>1.050*T5*T3;


T8:=(C-REF(C,26))/REF(C,26)*10*T3;


T9:=T7*T3;


T10:=T8<-2.30 AND T3;


T11:=T4<-2.7 AND T3;


T12:=T9 AND T10 AND T11 AND T3;


T13:=CROSS(0.5,T12)*T3;


T14:=CROSS(T13,0.5)*T3;


T15:=BARSLAST(T14=1)*T3;


T16:=T15<=5 AND C<REF(C,T15) AND T3;


买2:=T13 OR T16;


T17:= (C-MA(C,2))/MA(C,2)*100;


T18:=INDEXC;


T19:=MA(T18,56);


T20:=T18/T19<0.94;


T21:=(C-REF(C,26))/REF(C,26)*10;


T22:=T20;


T23:=T21<-2.55;


T24:=T17<-2.7;


T25:=T22 AND T23 AND T24;


T26:=CROSS(0.5,T25);


T27:=CROSS(T26,0.5);


T28:=BARSLAST(T27=1);


T29:=T28<=5 AND C<1.02*REF(C,T28);


底4:=T26 OR T29;


T30:= (C-MA(C,2))/MA(C,2)*100;


T31:=INDEXC;


T32:=MA(T31,13);


T33:=T32>1.050*T31;


T34:=(C-REF(C,26))/REF(C,26)*10;


T35:=T33;


T36:=T34<-2.69;


T37:=T30<-3.09;


T38:=T35 AND T36 AND T37;


T39:=CROSS(0.5,T38);


T40:=CROSS(T39,0.5);


T41:=BARSLAST(T40=1);


T42:=T41<=5 AND C<REF(C,T41);


买3:=COUNT(T39 OR T42,4)=4;


T43:=EMA(((C*1.1-LLV(LOW,630))/(HHV(HIGH,630)-LLV(LOW,630))-(C*0.9-LLV(LOW,630))/(HHV(HIGH,630)-LLV(LOW,630)))*80,5);


T44:=INDEXC;


T45:=MA(T44,5);


T46:=MA(T44,20);


T47:=MA(T44,30);


T48:=T45>T44*1.03 AND T46>T44*1.13;


T49:=T48;


目标:=COUNT(T43<6 AND T49,3)>=3;


新目标:=买3 OR 目标;


神剑出鞘:IF(((COUNT(买1 AND 底4,6)=6 OR COUNT(买1 AND 买2,4)=4 OR COUNT(买2 AND 底4,5)=5) OR 新目标) AND DATE<=1280831,90,0),COLORRED,LINETHICK3;


DRAWTEXT(FILTER(神剑出鞘,5),90,'买'),COLORRED;


DRAWTEXT(FILTER(神剑出鞘,5),90,'买'),COLORRED;


版权声明

本文版权归掌上指标所有。
未经许可,不得转载,转载请注明出处!

服务热线

18020657357

微信客服

微信客服