上涨确认-精品通达信指标公式源码分享

通达信免费指标 06-10 阅读:32 评论:0

image.png

SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,13)/HHV(C,13))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,13)/HHV(C,13))*100);

上涨确认线:EMA((LLV(L,5)+(((EMA(((C-LLV(L,13))/(HHV(H,13)-LLV(L,13))*0.8*C),3)-((C-LLV(L,13))/(HHV(H,13)-LLV(L,13))*0.8*C))*5)*0.8+LLV(L,5))+((EMA((C-LLV(L,13))/(HHV(H,13)-LLV(L,13))*0.8*C,3)-((C-LLV(L,13))/(HHV(H,13)-LLV(L,13))*0.8*C))*5))/3,5),coloryellow;

LIANG:=(CLOSE - LLV(LOW,21)) / (HHV(HIGH,21) - LLV(LOW,21)) * 1.2 * CLOSE;

LIANG1:=EMA(LIANG,3);

LIANG2:=EMA(LIANG,5);

LIANG3:=EMA(LIANG,7);

 STICKLINE(LIANG1 >= LIANG2,LIANG3,LIANG1,10,0),color0000AA;

 STICKLINE(LIANG1 >= LIANG2,LIANG3,LIANG1,7,0),color0000BB;

 STICKLINE(LIANG1 >= LIANG2,LIANG3,LIANG1,6,0),color0000CC;

 STICKLINE(LIANG1 >= LIANG2,LIANG3,LIANG1,5,0),color0000DD;

 STICKLINE(LIANG1 >= LIANG2,LIANG3,LIANG1,4,0),color0000EE;

 STICKLINE(LIANG1 >= LIANG2,LIANG3,LIANG1,3,0),color0000FF;

STICKLINE(LIANG1 <= LIANG2,LIANG3,LIANG1,10,0),colorFF0000;

 STICKLINE(LIANG1 <= LIANG2,LIANG3,LIANG1,7,0),colorFF3300;

 STICKLINE(LIANG1 <= LIANG2,LIANG3,LIANG1,6,0),colorFF5500;

 STICKLINE(LIANG1 <= LIANG2,LIANG3,LIANG1,5,0),colorFF7700;

 STICKLINE(LIANG1 <= LIANG2,LIANG3,LIANG1,4,0),colorFF9900;

 STICKLINE(LIANG1 <= LIANG2,LIANG3,LIANG1,3,0),colorFFBB00;

 STICKLINE(LIANG1 <= LIANG2,LIANG3,LIANG1,2,0),colorFFDD00;

 STICKLINE(LIANG1 <= LIANG2,LIANG3,LIANG1,1,0),colorFFFF00;

 T1:=LIANG2 >= LIANG3 AND LIANG1 < REF(LIANG1,1);

 T2:=LIANG2 < LIANG3 AND LIANG1 > REF(LIANG1,1);

 STICKLINE(T1,LIANG1,LIANG3,10,0),colorFFBB11;

 STICKLINE(T1,LIANG1,LIANG3,7,0),colorFFCC22;

 STICKLINE(T1,LIANG1,LIANG3,5,0),colorFFDD33;

 STICKLINE(T1,LIANG1,LIANG3,3,0),colorFFEE44;

 STICKLINE(T1,LIANG1,LIANG3,1,0),colorFFFF55;

STICKLINE(T2,LIANG1,LIANG3,10,0),color338FDD;

 STICKLINE(T2,LIANG1,LIANG3,8,0),colorFF00FF;

 STICKLINE(T2,LIANG1,LIANG3,1,0),color00DDFF;

 STICKLINE(T2,LIANG1,LIANG3,8,0),color00AAFF;

 STICKLINE(T2,LIANG1,LIANG3,6.6,0),color00BBFF;

 STICKLINE(T2,LIANG1,LIANG3,4.4,0),color00CCFF;

 STICKLINE(T2,LIANG1,LIANG3,3.3,0),color00DDFF;

 STICKLINE(T2,LIANG1,LIANG3,2.2,0),color00EEFF;


版权声明

本文版权归掌上指标所有。
未经许可,不得转载,转载请注明出处!

服务热线

18020657357

微信客服

微信客服