量价控盘程度 -精品通达信指标公式源码分享

通达信免费指标 05-16 阅读:113 评论:0

image.png

VAR1:=1;VAR2:=CLOSE;VAR3:=VOL/IF(HIGH=LOW,4,HIGH-LOW);VAR4:=IF(CAPITAL=0,VAR3*(VAR2-MIN(CLOSE,OPEN)),VAR3*IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW))*0.5;VAR5:=IF(CAPITAL=0,VAR3*(MIN(OPEN,CLOSE)-LOW),VAR3*IF(HIGH=LOW,1,VAR2-MIN(CLOSE,OPEN)))*1.5;VAR6:=IF(CAPITAL=0,VAR3*(HIGH-MAX(OPEN,CLOSE)),VAR3*IF(HIGH=LOW,1,HIGH-MAX(OPEN,CLOSE)))*0.5;VAR7:=IF(CAPITAL=0,VAR3*(MAX(CLOSE,OPEN)-VAR2),VAR3*IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-VAR2))*1.5;VAR8:=(VAR6+VAR5)*2.5;VAR9:=(VAR4+VAR7)*2.5;VAR10:=SUM(VAR8,10)-SUM(VAR9,10);VAR11:=35;VAR12:=35;VAR13:=3;VAR14:=(HHV(VAR10,VAR11)-CLOSE)/(HHV(VAR10,VAR11)-LLV(VAR10,VAR11))*100-VAR12;VAR15:=SMA(VAR14,VAR11,1)+100;VAR16:=(VAR10-LLV(VAR10,VAR11))/(HHV(VAR10,VAR11)-LLV(VAR10,VAR11))*100;VAR17:=SMA(VAR16,3,1);VAR18:=SMA(VAR17,3,1)+100;VAR19:=VAR18-VAR15;VAR20:=IF(VAR19>VAR13,VAR19-VAR13,0)*VAR1;量~控盘程度:VAR20,COLORCYAN;STICKLINE(VAR20>REF(VAR20,1),REF(VAR20,1),VAR20,3,0),COLORYELLOW;STICKLINE(VAR20>REF(VAR20,1),REF(VAR20,1),VAR20,2,0),COLOR0EBFF3;VAR21:=(HHV(HIGH,VAR11)-CLOSE)/(HHV(HIGH,VAR11)-LLV(LOW,VAR11))*100-VAR12;VAR22:=SMA(VAR21,VAR11,1)+100;VAR23:=(CLOSE-LLV(LOW,VAR11))/(HHV(HIGH,VAR11)-LLV(LOW,VAR11))*100;VAR24:=SMA(VAR23,3,1);VAR25:=SMA(VAR24,3,1)+100;VAR26:=VAR25-VAR22;VAR27:=IF(VAR26>VAR13,VAR26-VAR13,0)*VAR1;价~控盘程度:VAR27,COLORLIRED;STICKLINE(VAR27>REF(VAR27,1),REF(VAR27,1),VAR27,3,0),COLOR262CFD;STICKLINE(VAR27>REF(VAR27,1),REF(VAR27,1),VAR27,2,0),COLORRED;NOTEXT0:IF(CURRBARSCOUNT>0,50,DRAWNULL),DOTLINE,COLORGRAY;VAR28:=STRCAT(HYBLOCK,8);VAR29:=STRCAT(VAR28,DYBLOCK);VAR30:=STRCAT(VAR29,8);DRAWTEXT_FIX(ISLASTBAR,0.1,0,0,STRCAT(VAR30,GNBLOCK)),COLORLIGRAY;DRAWTEXT_FIX(VAR1=0,0.5,0.7,0,53);

版权声明

本文版权归掌上指标所有。
未经许可,不得转载,转载请注明出处!

服务热线

18020657357

微信客服

微信客服