分时神线-精品通达信指标公式源码分享

通达信免费指标 04-02 阅读:40 评论:0

微信截图_20190715230746.png

现价:CLOSE,COLORWHITE,LINETHICK1;


AGS1:=(BARSLAST(((HOUR = 9) AND (MINUTE = 31))) + 1);


AGS2:=SUM(CLOSE*VOL,BARSCOUNT(C))/SUM(VOL,BARSCOUNT(C));


AGS3:=(SUM((CLOSE * VOL),0) / SUM(VOL,0));


AGS4:=(((SETCODE = 0) OR (SETCODE = 1)) AND (CLOSE < 500));


均价:=IF(AGS4,AGS2,AGS3),COLORYELLOW;


AGS11:=MA((REF(MAX(H,REF(C,1)),1)-REF(MIN(L,REF(C,1)),1))/REF(C,2)*100,5)/4;


AGS12:=(AGS11 * 1.3);


AGS15:=((CLOSE > REF(CLOSE,1)) AND ((CLOSE / 均价) > (1 + (AGS11 / 100))));


AGS16:=((CLOSE < REF(CLOSE,1)) AND ((CLOSE / 均价) < (1 - (AGS11 / 100))));


HH1:=((REF(SUM(AGS15,0),1) = 0) AND (SUM(AGS15,0) = 1));


LL1:=((REF(SUM(AGS16,0),1) = 0) AND (SUM(AGS16,0) = 1));


AGS19:=(SUM(HH1,0) * CROSS(COUNT((CLOSE < REF(CLOSE,1)),BARSLAST(HH1)),0.5));


AGS20:=(SUM(LL1,0) * CROSS(COUNT((CLOSE > REF(CLOSE,1)),BARSLAST(LL1)),0.5));


CS1:CONST(SUM(IF(AGS19,REF(CLOSE,1),DRAWNULL),0)),COLORGREEN,LINETHICK1;


CB1:CONST(SUM(IF(AGS20,REF(CLOSE,1),DRAWNULL),0)),COLORLIMAGENTA,LINETHICK1;


HH2:=CROSS(SUM((AGS15 AND (CLOSE > (CS1 * (1 + (AGS12 / 100))))),0),0.5);


LL2:=CROSS(SUM((AGS16 AND (CLOSE < (CB1 * (1 - (AGS12 / 100))))),0),0.5);


AGS25:=(SUM(HH2,0) * CROSS(COUNT((CLOSE < REF(CLOSE,1)),BARSLAST(HH2)),0.5));


AGS26:=(SUM(LL2,0) * CROSS(COUNT((CLOSE > REF(CLOSE,1)),BARSLAST(LL2)),0.5));


CS2:CONST(SUM(IF(AGS25,REF(CLOSE,1),DRAWNULL),0)),COLORGREEN,LINETHICK1;


CB2:CONST(SUM(IF(AGS26,REF(CLOSE,1),DRAWNULL),0)),COLORLIMAGENTA,LINETHICK1;


DRAWICON((HH1 OR HH2),(CLOSE * 1.001),2);


DRAWICON((LL1 OR LL2),(CLOSE * 0.988),1);


DRAWICON((AGS20 OR AGS26),(REF(C,1) * 0.988),7);


DRAWICON((AGS19 OR AGS25),(REF(CLOSE,1) * 1.001),8);


版权声明

本文版权归掌上指标所有。
未经许可,不得转载,转载请注明出处!

服务热线

18020657357

微信客服

微信客服