出击逃遁-精品通达信指标公式源码分享

通达信免费指标 03-08 阅读:60 评论:0

image.png

A0:=(L+H+C*2)/4;

A1:EMA(A0,14)COLORBLUE,LINETHICK2;

A2:=EMA(A0,25)COLORLIBLUE,LINETHICK2;

A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;

A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;

出击:IF(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))),DRAWNULL),COLORMAGENTA,LINETHICK2;

逃遁:IF(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))),DRAWNULL),COLORGREEN,LINETHICK2;

盈10%:IF(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.1,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.1,DRAWNULL),COLORWHITE,POINTDOT;

盈20%:IF(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.2,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.2,DRAWNULL),COLORWHITE,POINTDOT;

盈30%:IF(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.3,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.3,DRAWNULL),COLORWHITE,POINTDOT;

盈40%:IF(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.4,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.4,DRAWNULL),COLORWHITE,POINTDOT;

盈50%:IF(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.5,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.5,DRAWNULL),COLORWHITE,POINTDOT;

铁:IF(A1X>=0,A1,DRAWNULL)COLORRED,LINETHICK2;

律:IF(A1X<0 AND A2X<0,A1,DRAWNULL)COLORGREEN,LINETHICK2;

STICKLINE(CROSS(A1X,0),H,L,0,0 ),COLOR9933FF;

STICKLINE(CROSS(A1X,0),C,O,3,0 ),COLOR0000CC; 

STICKLINE(CROSS(A1X,0),C,O,1,0 ),COLOR0033FF; 

STICKLINE(CROSS(0,A1X),L,H,0,0 ),COLOR66CC33;

STICKLINE(CROSS(0,A1X),C,O,3,0),COLOR00CC00;

STICKLINE(CROSS(0,A1X),C,O,1,0),COLOR66FF00;


版权声明

本文版权归掌上指标所有。
未经许可,不得转载,转载请注明出处!

服务热线

18020657357

微信客服

微信客服