【通达信源码分享】精品指标公式-主力持仓量

通达信免费指标 11-22 阅读:252 评论:0

换手:=V*100/CAPITAL;

主力:=MA(换手,4);

大户:=MA(换手,9);

中户:=MA(换手,17);

散户:=MA(换手,34);

均量:=(主力+大户+中户+散户)/4;

主力能量:(主力-均量)COLORRED,NODRAW;

大户量:(大户-均量)COLORMAGENTA,NODRAW;

中户量:(中户-均量)COLORYELLOW,NODRAW;

散户量:(散户-均量),NODRAW;

操盘:STICKLINE(主力能量>=0 AND 主力能量>=REF(主力能量,1),4.5,4.5+主力能量,1,0),COLORRED;

减仓:STICKLINE(主力能量>=0 AND 主力能量< REF(主力能量,1),4.5,4.5+主力能量,1,0),COLOR00CC20;

反弹:STICKLINE(主力能量<0 AND 主力能量>=REF(主力能量,1),4.5,4.5+主力能量,1,0),COLOR00CCCC;

寻底:STICKLINE(主力能量<0 AND 主力能量< REF(主力能量,1),4.5,4.5+主力能量,1,0),COLORFF9900;

DRAWTEXT(ISLASTBAR=1,IF(主力能量>=0,4.2,4.8),'机构'),COLORRED;

操盘1:STICKLINE(大户量>=0 AND 大户量>=REF(大户量,1),3,3+大户量,1,0),COLORRED;

减仓1:STICKLINE(大户量>=0 AND 大户量< REF(大户量,1),3,3+大户量,1,0),COLOR00CC20;

反弹1:STICKLINE(大户量<0 AND 大户量>=REF(大户量,1),3,3+大户量,1,0),COLOR00CCCC;

寻底1:STICKLINE(大户量<0 AND 大户量< REF(大户量,1),3,3+大户量,1,0),COLORFF9900;

DRAWTEXT(ISLASTBAR=1,IF(大户量>=0,2.7,3.3),'大户'),COLORMAGENTA;

操盘2:STICKLINE(中户量>=0 AND 中户量>=REF(中户量,1),1.5,1.5+中户量,1,0),COLORRED;

减仓2:STICKLINE(中户量>=0 AND 中户量< REF(中户量,1),1.5,1.5+中户量,1,0),COLOR00CC20;

反弹2:STICKLINE(中户量<0 AND 中户量>=REF(中户量,1),1.5,1.5+中户量,1,0),COLOR00CCCC;

寻底2:STICKLINE(中户量<0 AND 中户量< REF(中户量,1),1.5,1.5+中户量,1,0),COLORFF9900;

DRAWTEXT(ISLASTBAR=1,IF(中户量>=0,1.2,1.8),'中户'),COLORYELLOW;

操盘3:STICKLINE(散户量>=0 AND 散户量>=REF(散户量,1),0,散户量,1,0),COLORRED;

减仓3:STICKLINE(散户量>=0 AND 散户量< REF(散户量,1),0,散户量,1,0),COLOR00CC20;

反弹3:STICKLINE(散户量<0 AND 散户量>=REF(散户量,1),0,散户量,1,0),COLOR00CCCC;

寻底3:STICKLINE(散户量<0 AND 散户量< REF(散户量,1),0,散户量,1,0),COLORFF9900;

DRAWTEXT(ISLASTBAR=1,IF(散户量>=0,-0.3,0.3),'散户'),COLORGREEN;

红买盘:MA(C,3),COLORRED,NODRAW;

绿卖盘:MA(C,3),COLORGREEN,NODRAW;

黄反弹:MA(C,3),COLORYELLOW,NODRAW;

蓝寻底:MA(C,3),COLORFF9900,NODRAW;

成交量:VOL,COLORWHITE,NODRAW;

均量5:MA(成交量,5)/50000,COLORMAGENTA;

均量20:MA(成交量,20)/50000,COLOR00FFFF;

均量120:MA(成交量,120)/50000,COLOR00CC20;

B:=ZIG(3,50/5)*1;

G:=MA(B,2);

D:=CROSS(B,G)*10;

W:=CROSS(G,B)*10;

DRAWTEXT(W=10,4,'卖' ),COLORWHITE;

DRAWTEXT(D=10,4,'买'),COLORCYAN;

image.png

版权声明

本文版权归掌上指标所有。
未经许可,不得转载,转载请注明出处!

服务热线

18020657357

微信客服

微信客服