【通达信源码分享】精品指标公式-班长画线

通达信免费指标 07-22 阅读:933 评论:0

A1:=REF(HIGH,3)=HHV(HIGH,2*3+1); B1:=FILTER(A1,3); C1:=BACKSET(B1,3+1); D1:=FILTER(C1,3);{高点};

A2:=REF(LOW,3)=LLV(LOW,2*3+1); B2:=FILTER(A2,3); C2:=BACKSET(B2,3+1); D2:=FILTER(C2,3);{低点};

E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2; E2:=(HIGH+LOW)/2;{高低点出现在同一K线上时可作取舍};

H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;

H2:=D1 AND NOT(D2 AND E1>=E2);

L1:=D2 AND NOT(D1 AND E1=E2);

X1:=REF(BARSLAST(H1),1)+1; AA:=LLVBARS(IF(L1,LOW,10000),X1); BB:=IF(AA,AA,X1); F1:=BACKSET(H1 AND COUNT(L1,X1)>0,BB);

G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1);{过滤后低点};

L2:=LD OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;

X2:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));

G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1);{过滤后高点};

DRAWLINE(LD,L,HD,H,0),COLORGRAY,LINETHICK1;

DRAWLINE(HD,H,LD,L,0),COLORGRAY,LINETHICK1;

J1:=BACKSET(ISLASTBAR,MIN(BARSLAST(HD),BARSLAST(LD))+1); J2:=J1>REF(J1,1);

DRAWLINE(J2,IF(HD,H,L),ISLASTBAR,IF(BARSLAST(HD)>BARSLAST(LD),H,L),0),COLORGRAY,LINETHICK1;

A3:=H; B3:=REF(H,REF(BARSLAST(HD),1)+1)>REF(H,REF(BARSLAST(HD),1)+2+REF(BARSLAST(HD),REF(BARSLAST(HD),1)+2));

D3:=A3 AND B3 AND HD; E3:=BACKSET(D3,REF(BARSLAST(HD),1)+2); HH:=E3>REF(E3,1);{找出全部长期高点};

A4:=L>REF(L,REF(BARSLAST(LD),1)+1);

B4:=REF(L,REF(BARSLAST(LD),1)+1); D4:=A4 AND B4 AND LD; E4:=BACKSET(D4,REF(BARSLAST(LD),1)+2); LL:=E4>REF(E4,1);{找出全部长期低点};

DRAWICON(HH,H,2);DRAWICON(LL,L,1);

H3:=HH OR ISLASTBAR OR BARSCOUNT(C)=1; {后面进行过滤,方法同前。只是不用考虑高低点出现在同一K线};

X3:=REF(BARSLAST(H3),1)+1; F3:=BACKSET(H3 AND COUNT(LL,X3)>0,LLVBARS(IF(LL,L,POW(10,20)),X3));

G3:=F3>REF(F3,1); I3:=BACKSET(G3,2); LZ:=I3>REF(I3,1); {长期低点,也可供引用};

L4:=LZ OR ISLASTBAR OR BARSCOUNT(C)=1;

X4:=REF(BARSLAST(L4),1)+1; F4:=BACKSET(L4 AND COUNT(HH,X4)>0,HHVBARS(IF(HH,H,-POW(10,20)),X4));

G4:=F4>REF(F4,1); I4:=BACKSET(G4,2); HZ:=I4>REF(I4,1);{长期高点,也可供引用};  

DRAWLINE(HZ,H,LZ,L,0),COLOR550088,LINETHICK1;

DRAWLINE(LZ,L,HZ,H,0),COLOR550088,LINETHICK1;{长期连线};

K1:=BACKSET(ISLASTBAR,MIN(BARSLAST(HZ),BARSLAST(LZ))+1); K2:=K1>REF(K1,1);

DRAWLINE(K2,IF(HZ,H,L),ISLASTBAR,C,0),COLOR550088,LINETHICK1; {最后的长期连线,连在收盘价上};

UU:=BACKSET(ISLASTBAR,BARSLAST(LD)+1);

VV:=UU>REF(UU,1);

WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);

XX:=WW>REF(WW,1);

DRAWLINE(XX,L,VV,L,1),COLOR6666FF;

UU2:=BACKSET(ISLASTBAR,BARSLAST(HD)+1);

VV2:=UU2>REF(UU2,1);

WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);

XX2:=WW2>REF(WW2,1);

DRAWLINE(XX2,H,VV2,H,1),COLOR6666FF;

前一低:REF(L,BARSLAST(VV)),COLOR99FF66,POINTDOT,LINETHICK4;

前二低:REF(L,BARSLAST(XX)),COLORYELLOW,CROSSDOT;

前一高:REF(H,BARSLAST(VV2)),COLOR99FF66,POINTDOT,LINETHICK4;

前二高:REF(H,BARSLAST(XX2)),COLORYELLOW,CROSSDOT;

短高:=REF(H,BARSLAST(VV2));

短低:=REF(L,BARSLAST(VV));

短比:(C-短低)/(短高-短低),LINETHICK0,NODRAW;

{以下语句为三角形部分}

底:REF(L,BARSLAST(VV)),COLORRED,LINETHICK2;

顶:REF(H,BARSLAST(VV2)),COLORGREEN,LINETHICK2;

{下跌三角形:蓝色三角形画完介入}

STICKLINE(VV,顶,底,0.1,0),COLORFF6633,LINETHICK3;

DRAWLINE(VV2,H,VV,L,0),COLORFF6633,LINETHICK3;{斜}

DRAWLINE(VV2,H,VV,顶,0),COLORFF6633,LINETHICK3;

{上涨三角形:红色三角形画完出局}

STICKLINE(VV2 ,顶,底,0.1,0),COLORRED,LINETHICK3;

DRAWLINE(VV,L,VV2,H,0),COLORRED,LINETHICK3;{斜}

DRAWLINE(VV,L,VV2,底,0),COLORRED,LINETHICK3;

{涨停变黄颜色}

STICKLINE(C>1.095*REF(C,1),C,O,2.5,0),COLORYELLOW;

{跌停变白颜色}

STICKLINE(C<0.905*REF(C,1),C,O,2.5,0),COLORGREEN;

微信截图_20230722204256.png

版权声明

本文版权归掌上指标所有。
未经许可,不得转载,转载请注明出处!

服务热线

18020657357

微信客服

微信客服