【通达信源码分享】精品指标公式-主图行业板块题材市值 叠加均线

通达信免费指标 04-16 阅读:540 评论:0

MA1:MA(CLOSE,5);

MA2:MA(CLOSE,10);

MA3:MA(CLOSE,20);

MA4:MA(CLOSE,30);

MA5:MA(CLOSE,60);

MA6:MA(CLOSE,120);

MA7:MA(CLOSE,251);

MA8:MA(CLOSE,500);

MA9:MA(CLOSE,1000);

MA10:MA(CLOSE,2000);

 

{板块市值业绩}

所属板块:=STRCAT('【所属板块】',STRCAT(STRCAT(STRCAT('     [行业]—',HYBLOCK),STRCAT('     [地域]—',DYBLOCK)),STRCAT('     [概念]—',GNBLOCK)));

总股本:=STRCAT(STRCAT('     总股本:',CON2STR(TOTALCAPITAL/1000000,2)),'亿');

流通盘:=STRCAT(STRCAT('     流通盘:',CON2STR(CAPITAL/1000000,2)),'亿');

全流通:=STRCAT(STRCAT('     流通比:',CON2STR(CAPITAL/TOTALCAPITAL*100,2)),'%');

市值:=STRCAT(STRCAT('     流通市值:',CON2STR((CAPITAL/1000000)*C,2)),'亿');

上市日期:=STRCAT('     上市日期: ',CON2STR(HHV((BARSCOUNT(C)=0)*(DATE+19000000),0),0));

股本市值:=STRCAT('【股本市值】',STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),上市日期));

市盈率:=STRCAT('     市盈率:',CON2STR(C/FINANCE(33),2));

市销率:=STRCAT('     市销率:',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));

市净率:=STRCAT('     市净率:',CON2STR(C/FINANCE(34),2));

净资收益率:=STRCAT('     净资收益率:',CON2STR(FINANCE(33)/FINANCE(34)*100,2));

毛利率:=STRCAT('     毛利率:',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));

净利润率:=STRCAT('     净利率:',CON2STR(FINANCE(30)/FINANCE(20)*100,2));

主营利润率:=STRCAT('     主营利润率:',CON2STR(FINANCE(23)/FINANCE(20)*100,2));

当前业绩:=STRCAT('【当前业绩】',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市盈率,市销率),市净率),净资收益率),毛利率),净利润率),主营利润率));

DRAWTEXT_FIX(ISLASTBAR,0.005,0.02,0,所属板块),COLORMAGENTA;

DRAWTEXT_FIX(ISLASTBAR,0.005,0.07,0,股本市值),COLORMAGENTA;

DRAWTEXT_FIX(ISLASTBAR,0.005,0.12,0,当前业绩),COLORMAGENTA;

DRAWTEXT_FIX(1,0.005,0.17,0,'莸利比例:'),COLORYELLOW;

DRAWNUMBER_FIX(1,0.06,0.17,0,CONST(WINNER(C )*100)),COLORYELLOW;

DRAWNUMBER_FIX(1,0.15,0.17,0,CONST(DYNAINFO(37)*100)),COLORYELLOW;

DRAWTEXT_FIX  (1,0.12,0.17,0,'换手:'),COLORYELLOW;

DRAWNUMBER_FIX(1,0.25,0.17,0,CONST(DYNAINFO(17))),COLORYELLOW;

DRAWTEXT_FIX  (1,0.22,0.17,0,'量比:'),COLORYELLOW;

DRAWTEXT_FIX  (1,0.30,0.17,0,'涨幅:'),COLORYELLOW;

DRAWNUMBER_FIX(1,0.33,0.17,0,CONST(DYNAINFO(14)*100)),COLORYELLOW;

DRAWNUMBER_FIX(1,0.33,0.17,0,IF(CONST(DYNAINFO(14)*100)<0,CONST(DYNAINFO(14)*100),DRAWNULL)),COLORYELLOW;

{}

X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;

X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};

X3:=FINANCE(23)/FINANCE(10)*3.3;

X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}

X5:=FINANCE(20)/FINANCE(15)*0.999;

Z值:=X1+X2+X3+X4+X5;

预警:=IF(Z值<1.2,'重警',IF(Z值>=1.2 AND Z值<2.6,'轻警','无警'));

财务预警:=STRCAT('财务预警: ',STRCAT(预警,STRCAT('-Z值: ',CON2STR(Z值,3))));

优质资产率:=STRCAT(' 优质资产率: ',CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2));{理论上越大越好但不同行业有不同标准};

现金负债比:=STRCAT(' 现金负债比: ',CON2STR(FINANCE(25)/FINANCE(15),3));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};

财务系数:=STRCAT('风险系数: ',STRCAT(STRCAT(财务预警,优质资产率),现金负债比));

DRAWTEXT_FIX(ISLASTBAR,0.005,0.23,0,财务系数),COLORGREEN;

30-1G023212032.png

版权声明

本文版权归掌上指标所有。
未经许可,不得转载,转载请注明出处!

服务热线

18020657357

微信客服

微信客服