【通达信源码分享】精品指标公式-OBV凯迪源码

通达信免费指标 04-09 阅读:358 评论:0

公式源码:


{金兰三宝}


NA:=9;


N1:=6;


N:=4;


MP:=14;


TYP := (HIGH + LOW + CLOSE)/3;


CC1:=(TYP-MA(TYP,MP))/(0.015*AVEDEV(TYP,MP)),COLORFF00FF;


C1:=SMA(CC1,3,1);


C2:=SMA(C1,3,1);


C3:=3*C1-2*C2;


CB1:=EMA(C3,5);


CB2:=REF(CB1,1);


LC:=REF(CLOSE,1);


RSI1:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;


RSIK:=(RSI1-50)*5,LINETHICK2,COLORFFFFFF;


R1:=SMA(RSIK,3,1);


D1:=SMA(R1,3,1);


J1A:=3*R1-2*D1;


RR1:=EMA(J1A,5);


RR2:=REF(RR1,1);


RR:=RR1>RR2;


RSV8:=(CLOSE-LLV(LOW,NA))/(HHV(HIGH,NA)-LLV(LOW,NA))*100;


KU:=SMA(RSV8,3,1);


K1:=(KU-50)*5,COLOR00FF00;


K2:=SMA(K1,3,1);


D2:=SMA(K2,3,1);


J2A:=3*K2-2*D2;


BB1:=EMA(J2A,5);


BB2:=REF(BB1,1);


金兰买入:=RR AND NOT(REF(RR,1)) AND (RR1<-100 AND BB1<-100) AND CB1<-100,,COLOR00DDFF;


{抄底特准}


VAR1T:=REF(CLOSE,1);


VAR2T:=SMA(MAX(CLOSE-VAR1T,0),7,1)/SMA(ABS(CLOSE-VAR1T),7,1)*100;


抄底特准:FILTER(REF(VAR2T,1)<20 AND VAR2T>REF(VAR2T,1),5),NODRAW,COLORFF00FF;


{极品底}


关注:=(MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04;


散户:= EMA(((2*CLOSE+HIGH+LOW)/4-LLV(LOW,5))/(HHV(HIGH,4)-LLV(LOW,5))*100,4); 


庄家:= EMA(0.667*REF(散户,1)+0.333*散户,2); 


低进1:=CROSS(散户,庄家) AND 散户<30;


K8:=SMA(RSV8,3,1); 


D8:=SMA(K8,3,1); 


J8:=3*K8-2*D8; 


X8:=LLV(J8,2)=LLV(J8,8); 


低进2:=CROSS(J8,REF(J8+0.01,1)) AND X8 AND J8<19;


A1:=(MA(C,5)-C)/C;


A2:=(MA(C,10)-MA(C,5))/MA(C,5); 


B1:=A1>0.04 AND A2>0.04 AND 低进1;


B2:=A1>0.04 AND A2>0.04 AND 低进2;


极品底:=B1 OR B2,COLOR0000FF;


波段底:抄底特准 AND 金兰买入 OR  REF(极品底,1) OR REF(极品底,2),COLOR00CCFF;


STICKLINE(波段底,100,0,2.8,0),COLOR555500;


STICKLINE(波段底,100,0,2,0),COLOR888800;


STICKLINE(波段底,100,0,1.5,0),COLORAAAA00;


STICKLINE(波段底,100,0,1,0),COLORCCCC00;


STICKLINE(波段底,100,0,0,0),COLOREEEE00;


{吸筹}


VAR2Q:=REF(LOW,1);


VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;


VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);


VAR5Q:=LLV(LOW,30);


VAR6Q:=HHV(VAR4Q,30);


VAR7Q:=IF(MA(CLOSE,58),1,0);


VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/618*VAR7Q;


VAR9Q:=IF(VAR8Q>100,100,VAR8Q);


吸筹:STICKLINE(VAR9Q>-120,0,VAR9Q,6,-1),COLORGRAY;


主力挖坑:=SUM(HIGH-OPEN,26)/SUM(OPEN-LOW,26)*100;


STICKLINE(主力挖坑<50,VAR9Q,0,3,0),COLOR5B0000;


 


{买卖奇准}


买:=MA(CLOSE,1);


卖:=(LOW+HIGH+CLOSE)/3;


奇:=MA(卖,5);


准:=HHV(奇,10);


小卖:IF(HHV((买<准),5),100,90),COLORLICYAN;


大卖:IF(HHV((买<准),10),100,80),COLORGREEN;


清仓:IF(HHV((买<准),15),100,70),COLORBLUE;


{捕捉大牛股之预警准确率98%}


TR2:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),7);


HD2:=HIGH-REF(HIGH,1);


LD2:=REF(LOW,1)-LOW;


DMP2:=SUM(IF(HD2>0 AND HD2>LD2,HD2,0),7);


DMM2:=SUM(IF(LD2>0 AND LD2>HD2,LD2,0),7);


PDI2:=DMP2*100/TR2;


MDI2:=DMM2*100/TR2;


ADX2:=MA(ABS(MDI2-PDI2)/(MDI2+PDI2)*100,3);


ADXR2:=(ADX2+REF(ADX2,3))/2;


神偷线:=((DMP2*100)/TR2);


辅助线:=((DMM2*100)/TR2);


趋势线:=MA(((ABS((辅助线 - 神偷线))/(辅助线 + 神偷线))*100),3);


大牛股:IF(ADX2>90 AND PDI2=0,40,0),COLORRED,LINETHICK1;


预警:IF(((趋势线 > 88) AND (神偷线 < 5.8)),60,0),COLORYELLOW;


 


 


OBV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/25000,1);


OBVE:=EMA(OBV,N);


RSV3:=(OBVE-LLV(OBVE,6))/(HHV(OBVE,6)-LLV(OBVE,6))*100;


K:SMA(RSV3,2,1),COLORWHITE;


D:SMA(K,2,1),COLORYELLOW;


J:3*K-2*D,COLORMAGENTA;


STICKLINE(J<0,J,0,1,0),COLORYELLOW;

30-1G023213921.png

版权声明

本文版权归掌上指标所有。
未经许可,不得转载,转载请注明出处!

服务热线

18020657357

微信客服

微信客服