【通达信源码分享】精品指标公式-短线起爆源码源码

通达信免费指标 03-05 阅读:795 评论:0

公式源码:


 


DRAWGBK(C>0,RGB(0,150,150),RGB(0,00,100),0,' ',0),LINETHICK2;


{DRAWBAND(MA(COST(90),10),RGB(0,40,0),L,RGB(50,0,0));,DOTLINE,COLORBROWN}


DRAWKLINE(H,O,L,C);


{均线}


 


牛熊线:MA(COST(90),10),LINETHICK2;


 


阳线:COUNT(C>O,100)NODRAW;


阴线:COUNT(C<O,100)NODRAW;


平线:COUNT(C=O,100) NODRAW;


{涨跌停K线}


 STICKLINE((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,1,0),COLORYELLOW;


 STICKLINE((REF(C,1)-C)*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,1,0),COLORWHITE;


DRAWTEXT_FIX(ISLASTBAR,0,0.02,0,STRCAT('地域:     ',DYBLOCK)),COLORYELLOW;


DRAWTEXT_FIX(ISLASTBAR,0.3,0.02,0,STRCAT('行    业:     ',HYBLOCK)),COLORYELLOW;


DRAWTEXT_FIX(ISLASTBAR,0,0.12,0,STRCAT('概    念:     ',GNBLOCK)),COLORRED; 


称帝:(COST(99)+COST(93)+COST(85))/3,COLORYELLOW,LINETHICK2;


IF(称帝>=REF(称帝,1),称帝,DRAWNULL),COLORYELLOW,LINETHICK2; 


IF(称帝< REF(称帝,1),称帝,DRAWNULL),COLORBLUE,LINETHICK2; 


 


X:=(3*C+L+O+H)/6;


多空线:(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)


+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)


+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+


REF(X,20))/210,COLORGREEN,LINETHICK2;


IF(多空线>=REF(多空线,1),多空线,DRAWNULL),COLORRED,LINETHICK2; 


IF(多空线< REF(多空线,1),多空线,DRAWNULL),COLORGREEN,LINETHICK2;


DRAWICON(CROSS( C ,多空线), C ,25),LINETHICK2;


DRAWTEXT(CROSS(C,多空线),LOW,'★低吸 '),COLORFFFFFF; 


V0:=多空线,COLOR00FF66;


V1:称帝,COLOR00FF66;


LC:=REF(CLOSE,1);


RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100; 


DRAWTEXT(CROSS(RSI,11),LOW,'★低吸 '),COLORFFFFFF;


AA1:=EMA(C,2);          { 短指数平滑移动平均线 }


BB1:=EMA(AA1,2);        { 平滑 }


A:=MA(BB1,3);           { 平均 }


AA2:=EMA((H+C+O)/3,18); { 长指数平滑移动平均线 }


DD3:=A>=AA2 AND C>AA2;  { 短>长,且收>长 }


DD4:=A<AA2 ;   { 短<长 }


DD5:=A>AA2 ;   { 短>长 }


DRAWTEXT(CROSS(84,RSI) , HIGH,'→ 注意 '),COLOR00FF00 ;


RSV1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;


KK:=SMA(RSV1,3,1);


DD:=SMA(KK,3,1);


JJ:=3*KK-2*DD;


M0:=BARSLAST(CROSS(DD,JJ));


警示线:REF(H,M0),COLORFFDD44,LINETHICK4,POINTDOT;{进场; 止赢; 止损; 黄}


STICKLINE(警示线,警示线,警示线,3.8,1),COLORFFDD44,LINETHICK4;


获利:DRAWICON(CROSS( 称帝 ,警示线), 称帝 ,25),LINETHICK2;


DRAWTEXT(FILTER(获利,8),警示线-0.05,'↖跟庄买进'),COLORGREEN;


STICKLINE(获利,OPEN,警示线,2,0),COLOR0000FF,LINETHICK2;


{跳空}


STICKLINE(REF(L,1)>H,H,REF(L,1),5,0),COLORGRAY;


STICKLINE(REF(H,1)<L,L,REF(H,1),5,0),COLORGRAY;


N:=5;M:=13;


上:EMA(C,3),COLORRED,LINETHICK0;


中:EMA(C,5),COLOR00FF00,LINETHICK0;


下:EMA(中,5),COLORWHITE,LINETHICK0;


超买:MA(C,10)*IF(CAPITAL=0,1.04,1.1),POINTDOT,COLORGREEN,LINETHICK2;


超卖:MA(C,10)*IF(CAPITAL=0,0.95,0.9),POINTDOT,COLORRED,LINETHICK2;


获利盘%:WINNER(CLOSE)*100,NODRAW,COLORWHITE;


{此句为计算获利盘比例,不需要可以不要}


趋势线:EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),42),POINTDOT,COLORFF00FF,LINETHICK0;


V01:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);


V2:=(1-7/100)*(DMA(CLOSE,V1));


V3:=(1+7/100)*(DMA(CLOSE,V1));


V5:=MA((LOW+HIGH+CLOSE)/3,5);


支撑:=REFDATE(V2,DATE),POINTDOT,LINETHICK3,COLORCC66FF;


阻力:=REFDATE(V3,DATE),POINTDOT,LINETHICK3,COLORGREEN;


MA1:=MEMA(CLOSE,5);


MA2:=ATAN((MA1/REF(MA1,1)-1)*100)*180/3.1416;


MA3:=IF(MA2>0,MA2,MA2);


MA5:=MA(CLOSE,N),COLOR888899;


MA13:=MA(CLOSE,M),COLORFF00F0,LINETHICK2;


VAR1:=CLOSE=HHV(C,4) AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3))


OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND


REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND


C>=REF(C,1) AND C>=REF(C,2);


VAR2:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);


VAR3:=CLOSE=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR


REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND


REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND


C<REF(C,1) AND C<REF(C,2);


VAR4:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND


REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);


VAR5:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND


REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND


REF(C,2)>=REF(C,4) AND C<REF(C,1);


VAR6:=V5>REF(V5,1) AND REF(V5,1)<REF(V5,2);


VAR7:=LOW<HHV(V5,13) AND HIGH>HHV(V5,13) AND CLOSE>REF(C,1) AND CLOSE>OPEN;


VAR8:=VAR7 AND COUNT(VAR6,2);


VAR9:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);


VAR10:=EMA(MA(C,13),13);


VAR11:=FILTER((LLV(VAR9,2)=LLV(VAR9,7) AND COUNT(VAR9<0,2) AND


CROSS(VAR9,MA(VAR9,2)))=1,5);


VAR12:=FILTER((HHV(VAR9,2)=HHV(VAR9,7) AND COUNT(VAR9>50,2) AND


CROSS(MA(VAR9,2),VAR9))=1,1);


VAR13:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;


VAR14:=FILTER(((CROSS(VAR13,0) OR CROSS(C,VAR10)) AND VAR11)=1,3);


VAR15:=MA(C,18)>=REF(MA(C,18),3) AND CROSS(C,MA(C,18));


VAR16:=VAR8 AND NOT(REF(VAR8,1));


强攻:=IF(MA3>REF(MA3,1) AND MA3>=0,MA13,DRAWNULL),COLORYELLOW,LINETHICK2;


回调:=IF(MA3<REF(MA3,1) AND MA3>0,MA13,DRAWNULL),COLORGREEN,LINETHICK2;


{KDJ}


RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;


K:=SMA(RSV,3,1);


D:=SMA(K,3,1);


J:=3*K-2*D;


金叉:=CROSS(J,D);


死叉:=CROSS(D,J);


买1:=(VAR14 OR VAR15) AND VAR11;


买2:=(VAR14 OR VAR15) AND VAR4;


买3:=(VAR14 OR VAR15) AND VAR2;


买4:=(VAR2 AND VAR11) OR (VAR4 AND VAR11);


买5:=(金叉 AND VAR4) OR (金叉 AND VAR2) OR (金叉 AND VAR11);


{涨停}


STICKLINE(CLOSE>REF(CLOSE,1)*1.0985 AND CLOSE=HIGH,CLOSE,OPEN,4,-1),


COLOR00FFFF;


{跌停}


STICKLINE(CLOSE<REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE,OPEN,4,-1),


COLORGREEN;


{蓝}


STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3.3,0),COLORFF7700;


STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.4,0),COLORFF9900;


STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.3,0),COLORFFBB00;


STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,0.8,0),COLORCYAN;


{红}


STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3.3,0),COLOR000099;


STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.4,0),COLOR0000CC;


STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.3,0),COLOR0000FF;


STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.8,0),COLORCC66FF;


{绿} 


STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,3.3,0),COLOR009900;


STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,2.4,0),COLOR00BB00; 


STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,1.3,0),COLOR00DD00; 


STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,0.8,0),COLOR00FF00;


{灰}


STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,3.3,0),COLOR999999;


STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,2.2,0),COLORBBBBBB; 


STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,1.3,0),COLORDDDDDD; 


STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,0.8,0),COLORFFFFFF;


STICKLINE(金叉,OPEN,CLOSE,1,0),COLORYELLOW;


STICKLINE(死叉,OPEN,CLOSE,1,0),COLOR000099;


DRAWICON(VAR16,LOW-0.02,7);


短线起爆:DRAWICON(买1 OR 买2 OR 买3 OR 买4 OR 买5,LOW-0.01,1);


DRAWTEXT((短线起爆=1),O-0.05,'★低吸 '),COLORFFFFFF;


DRAWICON(死叉 OR VAR12 OR CROSS(40,VAR9),HIGH+0.01,2);

30-1G025132225.png

版权声明

本文版权归掌上指标所有。
未经许可,不得转载,转载请注明出处!

服务热线

18020657357

微信客服

微信客服