【通达信分享源码】精品指标公式-自用MACD(源码、副图、通达信、贴图)

如题,自用MACD 现在本人珍藏多年的精品MACD指标共享给各位战友!MACD为波段指标之王。

在基本MACD基础上加入了金叉,死叉,空中加油,绿柱拐点,红柱拐点提示。极具实战意义。



MACD为波段指标之王。

在基本MACD基础上加入了金叉,死叉,空中加油,绿柱拐点,红柱拐点提示。极具实战意义。

 


DIF:EMA(CLOSE,12)-EMA(CLOSE,26),COLORRED;

DEA:EMA(DIF,9),COLORYELLOW;

MACD:(DIF-DEA)*2,COLORSTICK;

金叉:CROSS(DIF,DEA),NODRAW;

死叉:CROSS(DEA,DIF),NODRAW;

DRAWICON(CROSS(DIF,DEA),DEA,1);

DRAWICON(CROSS(DEA,DIF),DIF,2);

空中加油:IF(DIF>REF(DIF,1) AND DIF>=DEA AND REF(DIF,1)<=REF(DIF,2) AND REF(DIF,1)>=REF(DEA,1) ,1,0),NODRAW;


DRAWICON(空中加油=1,DIF,23);

红柱拐点:IF(MACD<REF(MACD,1) AND REF(MACD,1)>REF(MACD,2) AND MACD>0.30,1,0),NODRAW;

DRAWICON(红柱拐点=1,MACD,2);

绿柱拐点:IF(MACD<=-0.30 AND MACD>REF(MACD,1) AND REF(MACD,1)<REF(MACD,2),1,0),NODRAW;

DRAWICON(绿柱拐点=1,MACD,1);



强:IF(DIF>=DEA,DIF,DRAWNULL),COLORRED,LINETHICK2;

弱:IF(DEA>=DIF,DEA,DRAWNULL),COLORBLUE,LINETHICK2;


STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR00BBFF;

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR00DDFF;

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0,0 ),COLOR00FFFF;

STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR0011EE;

STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR0033DD;

STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0,0 ),COLOR0055FF;

STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORBB11BB;

STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORDD33BB;

STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0,0 ),COLORFF55BB;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORFFBB11;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORFFDD33;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0,0 ),COLORFFFF55;

服务热线

18020657357

微信客服

微信客服