【通达信源码分享】智能操盘主图指标源码

DRAWTEXT_FIX(1,0.0,0.00,0,EXTERNSTR(0,1))COLOR0077FF;


N8:=STRCAT(CON2STR(YEAR,0),' 年 '); 


Y8:=STRCAT(CON2STR(MONTH,0),' 月 '); 


R8:=STRCAT(CON2STR(DAY,0),' 日 '); 


买线:=EMA(C,2); 


卖线:=EMA(SLOPE(C,21)*20+C,42); 


STICKLINE(买线>=卖线,REFDATE(HHV(H,130),DATE),REFDATE(LLV(L,130),DATE),5,0),COLOR000055;


STICKLINE(买线<卖线,REFDATE(HHV(H,130),DATE),REFDATE(LLV(L,130),DATE),5,0),COLOR663300;  


DRAWNUMBER(ISLASTBAR  ,C,C),COLORMAGENTA;


VAR1:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));


VAR2:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));


VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));


SJTJ:=DATE<1590301;


X1:=(C+L+H)/3; 


X2:=EMA(X1,6); 


X3:=EMA(X2,5);


SJ8:=STRCAT(STRCAT(N8,Y8), R8); 


STICKLINE(X2>=X3 AND SJTJ,LOW,HIGH,0,1),COLORRED; 


STICKLINE(X2>=X3 AND SJTJ,CLOSE,OPEN,3.2,2),COLORRED; 


STICKLINE(X2<X3 AND SJTJ,LOW,HIGH,0,1),COLORCYAN;


STICKLINE(X2<X3 AND SJTJ,CLOSE,OPEN,3.2,2),COLORCYAN;


STICKLINE(CROSS(X3,X2) AND SJTJ,OPEN,CLOSE,3.2,0),COLORCYAN;


STICKLINE(CROSS(X2,X3) AND SJTJ,OPEN,CLOSE,3.2,0),COLORRED; 


STICKLINE((CLOSE>OPEN) AND (X2<X3) AND SJTJ,CLOSE,OPEN,3.2,2)COLORCYAN;


STICKLINE((CLOSE>OPEN) AND (X2>=X3) AND SJTJ,CLOSE,OPEN,3.2,2)COLORRED;


STICKLINE((CLOSE<OPEN) AND (X2<X3) AND SJTJ,CLOSE,OPEN,3.2,0)COLORCYAN;


STICKLINE((CLOSE<OPEN) AND (X2>=X3) AND SJTJ,CLOSE,OPEN,3.2,0)COLORRED;


做空:IF(SAR(10,2,20)>=H,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORBLUE; 


做多:IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORRED; 


操盘线:=EMA(EMA(EMA(CLOSE,2),2),2);


趋势线:(MA(操盘线,5)),COLORCYAN,LINETHICK2;


IF(趋势线>REF(趋势线,1),趋势线,DRAWNULL),COLORRED,LINETHICK2;


IF(趋势线<REF(趋势线,1),趋势线,DRAWNULL),COLORGREEN,LINETHICK2;


最新价:IF(SJTJ, C,DRAWNULL),LINETHICK0,COLORYELLOW;


DRAWTEXT_FIX(C>0,0.88,0,0,SJ8),COLOR00FFFF;


DRAWBMP(CROSS(VAR2,MA(VAR3,6)),(LOW - (LOW*0.01)),'BUY1');


DRAWBMP(CROSS(MA(VAR3,6),VAR1),(HIGH+(HIGH*0.03)),'SELL1');

30-1G125221304.png

服务热线

18020657357

微信客服

微信客服