【通达信分享源码】多空决策指标源码

{SUPERTREND-通达信版}


N:=10;M:=1.5;


TR1:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));


ATR:=MA(TR1,N);


MEDIAN:=(HIGH + LOW)/2;


UP:=MEDIAN+ATR*M;


DN:=MEDIAN-ATR*M;


A:=BARSLAST(C>=REF(LLV(MEDIAN+ATR*1.4,3),1));


B:=BARSLAST(C<=REF(HHV(MEDIAN-ATR*1.7,3),1));


D:=BARSLAST(C>=REF(HHV(MEDIAN+EMA(TR1,N),3),1));


E:=HHV(MEDIAN-ATR*1.5,D+1);


T1:=COUNT(CROSS(E,C),3)>=1 AND B>A;


T2:=(C>E AND B>A) OR (COUNT(CROSS(E,C),3)>=1 AND B>A);


IF(T2>0,HHV((H+L)/2-ATR*M,10),DRAWNULL),COLORDC00DC;


IF(T2=0,LLV((H+L)/2+ATR*M,10),DRAWNULL),COLOR00DC00;


STICKLINE(T2>0 AND H>MAX(C,O),H,MAX(C,O),0,0),COLOR5454FF;


STICKLINE(T2>0 AND L<MIN(C,O),L,MIN(C,O),0,0),COLOR5454FF;


STICKLINE(T2>0 AND C>=O,C,O,2,1),COLOR5454FF;


STICKLINE(T2>0 AND C<=O,C,O,2,0),COLOR5454FF;


STICKLINE(T2=0 AND H>MAX(C,O),H,MAX(C,O),0,0),COLORFFFF54;


STICKLINE(T2=0 AND L<MIN(C,O),L,MIN(C,O),0,0),COLORFFFF54;


STICKLINE(T2=0 AND C>=O,C,O,2,1),COLORFFFF54;


STICKLINE(T2=0 AND C<=O,C,O,2,0),COLORFFFF54;

30-1G125221203.png

服务热线

18020657357

微信客服

微信客服