【通达信源码分享】布林线的新玩法源码主图 适用于期货黄金白银外汇

公式源码:


A1:=DATE <= 1170615;


A2:=(100 * (CLOSE - (MA(CLOSE,30)))) / (MA(CLOSE,30));


A3:=100 - ((90 * ((HHV(HIGH,20)) - CLOSE)) / ((HHV(HIGH,20)) - (LLV(LOW,20))));


A4:=100 - (MA(((100 * ((HHV(HIGH,6)) - CLOSE)) / ((HHV(HIGH,6)) - (LLV(LOW,6)))),28));


A5:=MA(A4,6);


红持股:IF((A3 < A5),A5,A3),COLORRED;


绿持币:IF((A3 > A5),A5,A3),COLORGREEN;


强弱:(A5),LINETHICK1,COLORYELLOW;


A6:=(3 * (SMA((((CLOSE - (LLV(LOW,27))) / ((HHV(HIGH,27)) - (LLV(LOW,27)))) * 100),5,1))) - (2 * (SMA((SMA((((CLOSE - (LLV(LOW,27))) / ((HHV(HIGH,27)) - (LLV(LOW,27)))) * 100),5,1)),3,1)));


A7:=(10);


百万测底:((CROSS(A6,A7)) * 75) * A1,LINETHICK2,COLOR0000FF;


A8:=(REF(CLOSE,1)) / CLOSE;


A9:=MIN((MA(((AMOUNT / VOL) / 100),15)),(EMA(((AMOUNT / VOL) / 100),15)));


A10:=((1 - ((SMA(((LOW * A8) - (A8 / 10)),6,1)) / (EMA(((AMOUNT / VOL) / 100),15)))) * 100) - (100 / 10);


A11:=((((1 - ((MA((LOW - (A8 / 10)),6)) / A9)) * (DMA(CLOSE,(VOL / CAPITAL)))) / (MA(LOW,6))) * 100) - (100 / 10);


A12:=((((A10 + (A11 / 10)) > 0) AND (DATE > 1000101)) AND (DATE < 1991231)) AND ((COUNT((((1 - (CLOSE / (REF(CLOSE,1)))) > 0.099) AND ((1 - ((REF(CLOSE,1)) / (REF(CLOSE,2)))) > 0.099)),20)) < 3);


A13:=(((((((A10 + (A11 / 10)) > -3.688) AND (DATE > 1000101)) AND (DATE < 1991231)) AND ((CLOSE / (REF(CLOSE,1))) > 1.02)) AND ((COUNT((((1 - (CLOSE / (REF(CLOSE,1)))) > 0.099) AND ((1 - ((REF(CLOSE,1)) / (REF(CLOSE,2)))) > 0.099)),20)) < 3)) AND (((REF(CLOSE,1)) / (REF(CLOSE,2))) < 0.95)) AND ((CLOSE / (HHV(HIGH,20))) < 0.855);


鼎牛黑码:((IF(((((100 < 100) AND ((A10 + (A11 / 10)) > 0)) AND (DATE > 1000101)) AND (DATE < 1991231)),(A12 = 1),(A13 = 1))) * 100) * A1,LINETHICK2,COLORRED;


A14:=EMA(CLOSE,8);


A15:=EMA(A14,20);


A16:=CROSS(A14,A15);


A17:=A14 < (EMA(CLOSE,120));


大波黑码起步:((A16 AND A17) * 75) * A1,LINETHICK2,COLORYELLOW;


A18:=SUM((IF((CLOSE > (REF(CLOSE,1))),VOL,(IF((CLOSE < (REF(CLOSE,1))),(0 - VOL),0)))),0);


A19:=SUMBARS(VOL,CAPITAL);


A20:=(IF((CLOSE > (LLV(CLOSE,A19))),1,-1)) * (IF((A18 > (LLV(A18,A19))),1,-1));


A21:=IF((A20 = -1),1,0);


A22:=(COUNT((A21 = 1),8)) > 2;


A23:=((SUM(AMOUNT,13)) / ((AMOUNT / VOL) / 100)) / 100;


A24:=DMA((((((3 * HIGH) + LOW) + OPEN) + (2 * CLOSE)) / 7),(VOL / A23));


A25:=(((CLOSE - A24) / A24) * 100) < -15;


A26:=((CLOSE - (MIN(((REF(CLOSE,5)) * 0.865),((REF(CLOSE,21)) * 0.772)))) / CLOSE) < 0.05;


A27:=REF(LOW,1);


A28:=((SMA(ABS((LOW - A27)),3,1)) / (SMA((MAX((LOW - A27),0)),3,1))) * 100;


A29:=EMA((IF((CLOSE * 1.2),(A28 * 10),(A28 / 10))),3);


A30:=LLV(LOW,38);


A31:=HHV(A29,38);


A32:=IF((LLV(LOW,90)),1,0);


A33:=((EMA((IF((LOW <= A30),((A29 + (A31 * 2)) / 2),0)),3)) / 618) * A32;


(STICKLINE(A33,0,A33,6,1)) ,COLORYELLOW;


底部不买你后悔:(IF(((A25 AND A26) AND A22),60,0)) * A1;


DRAWTEXT_FIX(1,0.02,0.90,0,'翔博资讯-正品标志'),COLOR00FFFF;

30-1G203205154.png

服务热线

18020657357

微信客服

微信客服