【通达信源码分享】趋势波浪指标源码 打破一买就跌,一卖就涨的投资魔咒!

什么是波浪


  波浪是指股票价格的波动,都与大自然的潮汐,波浪一样,一浪跟着一浪,周而复始,具有相当程度的规律性,以一种"可识别的模式"前进和反转,这些模式在形态上不断重复(不一定在时间和幅度上重复)。


公式源码:


 


P:=14;WW:=(LLV(H,55)+HHV(L,55))/2;


WW2:=(C*4+L*3+H*2+O)/10;


OBV:=WW2;


A1:=REF(OBV,P)=HHV(OBV,2*P+1);


B1:=FILTER(A1,P);


C1:=BACKSET(B1,P+1);


D1:=FILTER(C1,P);


A2:=REF(OBV,P)=LLV(OBV,2*P+1);


B2:=FILTER(A2,P);


C2:=BACKSET(B2,P+1);


D2:=FILTER(C2,P);


A111:=REF(H,3)=HHV(H,2*6+1);


B111:=FILTER(A111,3);


C111:=BACKSET(B111,3+1);


D111:=FILTER(C111,3+1);


A112:=REF(L,3)=LLV(L,2*6+1);


B112:=FILTER(A112,3+1);


C112:=BACKSET(B112,3+1);


D112:=FILTER(C112,3);


E111:=(REF(LLV(L,2*3),1)+REF(HHV(H,2*3),1))/2;


E112:=(H+L)/2;


H111:=(D111 AND NOT(D112 AND E111>=E112)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;


L111:=(D112 AND NOT(D111 AND E111<E112));


H112:=D111 AND NOT(D112 AND E111>=E112);


X111:=REF(BARSLAST(H111),1)+1;


 F111:=BACKSET(H111 AND COUNT(L111,X111)>0,LLVBARS(IF(L111,LOW,10000),X111));


G111:=F111>REF(F111,1);


I111:=BACKSET(G111,2);


LD:=I111>REF(I111,1);


L112:=LD OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;


X112:=REF(BARSLAST(L112),1)+1;


F112:=BACKSET(L112 AND COUNT(H112,X112)>0,HHVBARS(IF(H112,HIGH,0),X112));


G112:=F112>REF(F112,1);


I112:=BACKSET(G112,2);HD:=I112>REF(I112,1);


实际上涨走势:DRAWLINE(LD,L,HD,H,0),COLORLIRED,DOTLINE;{WWW.88GS.COM}


实际下跌走势:DRAWLINE(HD,H,LD,L,0),COLORLIGREEN,DOTLINE;


J111:=BACKSET(BARSTATUS=2 ,MIN(BARSLAST(HD),BARSLAST(LD))+1);


J112:=J111>REF(J111,1);


预测走势:DRAWLINE(J112,IF(HD,H,L),BARSTATUS=2,IF(BARSLAST(HD)>BARSLAST(LD),H,L),0),COLORYELLOW,DOTLINE;


DRAWTEXT(LD AND BARSLAST(HD)<BARSLAST(REF(LD,1)) ,L*0.99,'  买入'),COLORYELLOW;


DRAWICON(LD AND BARSLAST(HD)<BARSLAST(REF(LD,1)) ,L*0.99,11);


DRAWTEXT(HD,H*1.01,'   卖出'),COLORCYAN;


DRAWICON(HD,H*1.01,15);

30-1P109135357.png

服务热线

18020657357

微信客服

微信客服