【通达信免费源码】一带箱路主图公式 趋势直观 源码

【通达信免费源码】一带箱路主图公式 趋势直观 源码

AA:MA(CLOSE,3.1415926535*MA(C,5))COLOR4080FF,NODRAW;

AC:=REF(AA,1);

TY:=C;

HD:=FILTER(BACKSET(FILTER(REF(TY,10)=HHV(TY,210+1),10),10+1),10)3.1415926535;

LD:=FILTER(BACKSET(FILTER(REF(TY,10)=LLV(TY,210+1),10),10+1),10)3.1415926535;

A1:=REF(C,BARSLAST(HD));

B1:=REF(C,BARSLAST(LD));

T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD);

T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);

前高:REF(H,BARSLAST(HD))COLORGREEN,NODRAW;

浪顶:IF(T1,A1,A1)COLORGREEN,NODRAW;

浪底:IF(T2,B1,B1)COLORFF00FF,NODRAW;

前低:REF(L,BARSLAST(LD))COLORFF00FF,NODRAW;

GA:MA(HIGH,3.1415926535*MA(H,5))COLORYELLOW,DOTLINE,NODRAW;

GH:IF((GA<=REF(GA,1)),GA,DRAWNULL),COLORCYAN,LINETHICK1,NODRAW;

DA:MA(LOW,3.1415926535*MA(L,5))COLORYELLOW,DOTLINE,NODRAW;

DL:IF((DA<=REF(DA,1)),DA,DRAWNULL),COLORCYAN,LINETHICK1,NODRAW;

DRAWBAND(GA,RGB(80,00,80),DA,DRAWNULL);

DRAWBAND(GH,RGB(43,83,78),DL,DRAWNULL);

DRAWBAND(浪底,RGB(225,0,0),前低,DRAWNULL);

STICKLINE(LOW<前低,前低,浪底,4,1)COLOR9F9F00;

STICKLINE(LOW>前低,前低,浪底,4,-1)COLORB400B4;

STICKLINE(AC<AA,(浪底-0.0001),(DA-0.017),4,0)COLOR000081;

STICKLINE(LOW>=前高,C,前高,2,-1){COLORB400B4}COLOR408080;

DRAWBAND(前高,RGB(225,0,0),浪顶,DRAWNULL);

STICKLINE(C<=前高,前高,浪顶,4,1)COLORGREEN;

STICKLINE(C>=前高,前高,浪顶,4,1)COLOR0000FF;

STICKLINE((AC>AA),(AC*1.001),(AC+0.018),2,1),COLORCYAN;

STICKLINE((AC<AA),(AC*1.001),(AC+0.018),2,1),COLOR4080FF;

DRAWRECTREL(0,5,1000,1,RGB(200,800,00));

DRAWRECTREL(0,202,1000,195,RGB(0,80,80));

DRAWRECTREL(0,498,1000,495,RGB(100,500,300));

DRAWRECTREL(0,808,1000,800,RGB(00,80,80));

DRAWRECTREL(0,1000,1000,995,RGB(200,800,00));

ZD:=DATE#WEEK;

ZH:=H#WEEK;

ZL:=L#WEEK;

K0:=ZD>REF(ZD,1) OR BARSSINCE(C)=0;

K1:=REFX(K0,1) OR ISLASTBAR;

S1:=MOD(SUM(K0,0),2);

N1:=20;

S2:=BACKSET(ISLASTBAR,SUMBARS(K0,N1));

STICKLINE((K0 OR K1) AND S2,ZH,ZL,0,-1),COLORFFFFFF;

DRAWLINE(K0 AND S1=1 AND S2,ZH,K1 AND S1=1 AND S2,ZH,0),COLORFFFFFF;

DRAWLINE(K0 AND S1=1 AND S2,ZL,K1 AND S1=1 AND S2,ZL,0),COLORFFFFFF;

DRAWLINE(K0 AND S1=0 AND S2,ZH,K1 AND S1=0 AND S2,ZH,0),COLORFFFFFF;

DRAWLINE(K0 AND S1=0 AND S2,ZL,K1 AND S1=0 AND S2,ZL,0),COLORFFFFFF;

IF((GA>=REF(GA,1)),GA,DRAWNULL)COLORYELLOW,DOTLINE;

IF((GA<=REF(GA,1)),GA,DRAWNULL),COLORCYAN,LINETHICK1;

IF((GA>=REF(GA,1)),DA,DRAWNULL)COLORYELLOW,DOTLINE;

IF((DA<=REF(DA,1)),DA,DRAWNULL),COLORCYAN,LINETHICK1;

日:=150;昨前:=3;

高1:=REF(HHV(H,日),昨前);

顶3:REFDATE(高1,DATE),COLORBLACK;

绝顶:=REFDATE(顶3,DATE),NODRAW;

跑:=绝顶=H AND ((C-L)<(O-C) OR (O-L)<(C-O)),NODRAW;

DRAWTEXT(跑,L*0.995,'逃命')COLORCYAN;

STICKLINE(跑,L,H,3.8,1),COLORFFFFFF;

DRAWKLINE(H,O,L,C);

STICKLINE(C<O,H,L,0,1)COLORFF9900;

STICKLINE(C<O,O,C,2.9,1)COLORFF9900;

STICKLINE(CLOSE>=OPEN AND CLOSE>=AA,H,L,0,1),COLORRED;

STICKLINE(CLOSE>=OPEN AND CLOSE>=AA,OPEN,CLOSE,3.0,0 ),COLOR000033;

STICKLINE(CLOSE>=OPEN AND CLOSE>=AA,OPEN,CLOSE,2.7,0 ),COLOR000066;

STICKLINE(CLOSE>=OPEN AND CLOSE>=AA,OPEN,CLOSE,2.1,0),COLOR000099;

STICKLINE(CLOSE>=OPEN AND CLOSE>=AA,OPEN,CLOSE,1.5,0 ),COLOR0000CC;

STICKLINE(CLOSE>=OPEN AND CLOSE>=AA,OPEN,CLOSE,0.9,0 ),COLOR0000FF;

STICKLINE(CLOSE>=OPEN AND CLOSE>=AA,OPEN,CLOSE,0.3,0 ),COLORCC66FF;

STICKLINE(OPEN>CLOSE AND CLOSE>AA,H,L,0,1),COLORFF9900;

STICKLINE(OPEN>CLOSE AND CLOSE>AA,OPEN,CLOSE,3.0,0 ),COLOR990000;

STICKLINE(OPEN>CLOSE AND CLOSE>AA,OPEN,CLOSE,3,0 ),COLORCC0000;

STICKLINE(OPEN>CLOSE AND CLOSE>AA,OPEN,CLOSE,2.1,0),COLORFF4400;

STICKLINE(OPEN>CLOSE AND CLOSE>AA,OPEN,CLOSE,1.5,0 ),COLORFF8800;

STICKLINE(OPEN>CLOSE AND CLOSE>AA,OPEN,CLOSE,0.9,0 ),COLORFFCC00;

STICKLINE(OPEN>CLOSE AND CLOSE>AA,OPEN,CLOSE,0.3,0 ),COLORCYAN;

A:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=9.8/100;

STICKLINE(A AND CLOSE=OPEN AND HIGH=LOW,REF(CLOSE,1),H,0,0),COLORYELLOW,LINETHICK1;

B:=(REF(CLOSE,1)-CLOSE)/CLOSE>=9.8/100;

STICKLINE(B AND CLOSE=OPEN AND HIGH=LOW,REF(CLOSE,1),H,0,0),COLORGREEN,LINETHICK1;

STICKLINE(A,H,L,0,1),COLORRED;

STICKLINE(A,O,C,2.5,0),COLOR008888;

STICKLINE(A,O,C,2,0),COLOR00AAAA;

STICKLINE(A,O,C,1,0),COLOR00CCCC;

STICKLINE(A,O,C,0.2,0),COLOR00FFFF;

STICKLINE(B,H,L,0,1),COLORGREEN;

STICKLINE(B,O,C,2.5,0),COLOR008800;

STICKLINE(B,O,C,2,0),COLOR00AA00;

STICKLINE(B,O,C,1,0),COLOR00CC00;

STICKLINE(B,O,C,0.2,0),COLOR00FF00;

STICKLINE(跑,C,O,3.0,0),COLOR777777;

STICKLINE(跑,C,O,2.7,0),COLORAAAAAA;

STICKLINE(跑,C,O,2.1,0),COLORCCCCCC;

STICKLINE(跑,C,O,0.9,0),,COLOR000000;

STICKLINE(跑,C,O,0.3,0),COLOR000000;


联系客服