彩色箱体主图-精品通达信指标公式源码分享

通达信免费指标 07-10 阅读:25 评论:0

image.png

H1:=LLV(LOW,20)+(HHV(HIGH,20)-LLV(LOW,20))/1000*(1000-200);


L1:=LLV(LOW,20)+(HHV(HIGH,20)-LLV(LOW,20))/1000*200;


HA:=REF(H1,1),COLORWHITE;


LA:=REF(L1,1),COLORWHITE;


HL:=HA-LA;


STICKLINE(CLOSE>MA(CLOSE,20) AND CLOSE>HA,O,C,3,0),COLORRED;


STICKLINE(CLOSE<MA(CLOSE,20) AND CLOSE<LA,O,C,3,0),COLORGREEN;


A1:=REF((HHV(HIGH,3)+LLV(LOW,3))/2,1);


STICKLINE(CLOSE>A1 AND CLOSE<HA AND CLOSE>LA,O,C,3,0),COLORWHITE;


STICKLINE(CLOSE<A1 AND CLOSE<HA AND CLOSE>LA,O,C,3,0),COLORBLUE;


今日参考:REF((HHV(HIGH,3)+LLV(LOW,3))/2,1),COLORYELLOW;


明日提示:(HHV(HIGH,3)+LLV(LOW,3))/2,COLORWHITE;


TODAYC:=CLOSE;


ATXT1:=LLV(LOW,20)+(HHV(HIGH,20)-LLV(LOW,20))/1000*875;


高抛:REF(ATXT1,1),COLORBLUE,DOTLINE;


ATXT2:=LLV(LOW,20)+(HHV(HIGH,20)-LLV(LOW,20))/1000*1191;


高估:REF(ATXT2,1),COLORRED,DOTLINE;


ATXT3:=LLV(LOW,20)+(HHV(HIGH,20)-LLV(LOW,20))/1000*125;


低吸:REF(ATXT3,1),COLORWHITE,DOTLINE;


ATXT4:=HHV(HIGH,20)-(HHV(HIGH,20)-LLV(LOW,20))/1000*1191;


低估:REF(ATXT4,1),COLORGREEN,DOTLINE;


牛熊线:REF((HHV(HIGH,60)+LLV(LOW,60))/2,1),DOTLINE,LINETHICK2,COLORYELLOW;


IF(CLOSE>牛熊线,牛熊线,DRAWNULL),COLORRED,LINETHICK2;


IF(CLOSE<牛熊线,牛熊线,DRAWNULL),COLORGREEN,LINETHICK2;


ZSZDF:=(REF(CLOSE,1)/今日参考-1)*100;


DRAWTEXT_FIX(CURRBARSCOUNT=1 AND 1<2,0,0,0,'今日参考:'),COLORWHITE;


DRAWNUMBER_FIX(CURRBARSCOUNT=1 AND 1<2,0.1,0,0,今日参考),COLORWHITE;


DRAWTEXT_FIX(CURRBARSCOUNT=1 AND 1<2,0.2,0,0,'明日提示:'),COLORYELLOW;


DRAWNUMBER_FIX(CURRBARSCOUNT=1 AND 1<2,0.3,0,0,明日提示),COLORYELLOW;


DRAWTEXT_FIX(CURRBARSCOUNT=1 AND (CLOSE>A1 AND CLOSE<HA AND CLOSE>LA),0,0.2,0,'白色反弹'),COLORWHITE;


DRAWTEXT_FIX(CURRBARSCOUNT=1 AND (CLOSE>MA(CLOSE,20) AND CLOSE>HA),0,0.2,0,'红色多头'),COLORRED;


DRAWTEXT_FIX(CURRBARSCOUNT=1 AND (CLOSE<A1 AND CLOSE<HA AND CLOSE>LA),0,0.2,0,'蓝色调整'),COLORCYAN;


DRAWTEXT_FIX(CURRBARSCOUNT=1 AND (CLOSE<MA(CLOSE,20) AND CLOSE<LA),0,0.2,0,'绿色空头'),COLORGREEN;


S8:=IF(CLOSE>MA(CLOSE,20) AND CLOSE>HA,4,0);


S7:=IF(CLOSE<A1 AND CLOSE<HA AND CLOSE>LA,3,0);


S2:=IF(CLOSE>A1 AND CLOSE<HA AND CLOSE>LA,2,0);


S1:=IF(CLOSE<MA(CLOSE,20) AND CLOSE<LA,1,0);


S6:=IF(REF(S8,1)=4 AND S7=3,423,0);


S5:=IF(REF(S8,1)=4 AND S2=2,422,0);


S4:=IF(REF(S7,1)=3 AND S1=1,321,0);


S3:=IF(REF(S2,1)=2 AND S1=1,221,0);


S9:=IF(REF(S1,1)=1 AND S2=2,122,0);


S10:=IF(REF(S2,1)=2 AND S8=4,224,0);


S11:=IF(REF(S7,1)=3 AND S8=4,324,0);


S12:=IF(REF(S7,1)=3 AND S2=2,322,0);


S13:=IF(REF(S1,1)=1 AND S8=4,124,0);


DRAWTEXT_FIX(CURRBARSCOUNT=1 AND S9=122,0.1,0.2,0,'空头转反弹'),COLORWHITE;


DRAWTEXT_FIX(CURRBARSCOUNT=1 AND S10=224,0.1,0.2,0,'反弹转多头'),COLORRED;


DRAWTEXT_FIX(CURRBARSCOUNT=1 AND S11=324,0.1,0.2,0,'调整转多头'),COLORRED;


DRAWTEXT_FIX(CURRBARSCOUNT=1 AND S12=322,0.1,0.2,0,'调整转反弹'),COLORWHITE;


DRAWTEXT_FIX(CURRBARSCOUNT=1 AND S13=124,0.1,0.2,0,'空头转多头'),COLORWHITE;


ZT:=(CLOSE/REF(CLOSE,1)-1>0.095 AND CLOSE=HIGH);


涨停天:=BARSLAST(ZT=1);


BL:=(AMO/REF(AMO,1)>2);


倍量天:=BARSLAST(BL=1);


DRAWTEXT_FIX(CURRBARSCOUNT=1 AND BL=1,0,0.3,0,'倍量'),COLORWHITE;


DRAWTEXT_FIX(CURRBARSCOUNT=1 AND ZT=1,0.05,0.3,0,'涨停'),COLORMAGENTA;


情绪:(OPEN-REF(CLOSE,1))/(REF(HIGH,1)-REF(LOW,1))*100,NODRAW,COLORYELLOW;


行为:(CLOSE-REF(CLOSE,1))/(REF(HIGH,1)-REF(LOW,1))*100,NODRAW,COLORMAGENTA;


空:(HIGH-CLOSE)/(HIGH-LOW)*100,NODRAW,COLORGREEN;


多:(100-空),NODRAW,COLORRED;


版权声明

本文版权归掌上指标所有。
未经许可,不得转载,转载请注明出处!

服务热线

18020657357

微信客服

微信客服