神秘曲线-精品通达信指标公式源码分享

通达信免费指标 06-11 阅读:25 评论:0

微信截图_20190609203113.png

趋势:SMA(((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100),3,1),COLORRED;

DRAWBAND(趋势,RGB(155,50,50),50,RGB(0,100,50));

判断:SMA(趋势,3,1),COLORYELLOW;

转强:IF(趋势>50,趋势,DRAWNULL),COLORRED;

转弱:IF(趋势<50,趋势,DRAWNULL),COLORGREEN;

拉升:IF(判断>50 AND 趋势>判断,判断,DRAWNULL),COLORYELLOW,LINETHICK2;

建仓:IF(判断<50 AND 趋势>判断,判断,DRAWNULL),COLORLIMAGENTA;

出货:IF(判断>50 AND 趋势<判断,判断,DRAWNULL),COLORLIGREEN,LINETHICK2;

RSV:=(CLOSE-LLV(CLOSE,3))/(HHV(CLOSE,3)-LLV(CLOSE,3))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

TYP:=(HIGH+LOW+CLOSE)/3;

CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));

DIFF:=EMA(CLOSE,2)-EMA(CLOSE,55);

DEA:=EMA(DIFF,6);

MACD:=2*(DIFF-DEA);

转点:=IF(K>D AND CCI>0 AND DIFF>DEA AND MACD>0,1,0);

STICKLINE(转点=1,48,52,2,0),COLORYELLOW;

STICKLINE(转点=0,50,50,2,0),COLORCYAN;

STICKLINE(C,90,90,1,0),COLORYELLOW;

STICKLINE(C,10,10,1,0),COLORCYAN;

持币:IF(SAR(10,2,20)>=H,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORGREEN;

持股:IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORRED;


版权声明

本文版权归掌上指标所有。
未经许可,不得转载,转载请注明出处!

服务热线

18020657357

微信客服

微信客服