筹码分布-精品通达信指标公式源码分享

通达信免费指标 03-04 阅读:66 评论:0

image.png

DA1:=IF(130>TOTALBARSCOUNT,TOTALBARSCOUNT,130);

DA:=IF(CURRBARSCOUNT>DA1,0,DA1);

HI:=REFDATE(HHV(H,DA),DATE);

LO:=REFDATE(LLV(L,DA),DATE);

C1:=IF(CURRBARSCOUNT<=DA,C,DRAWNULL);

GZ:=EXP(LN(HI/LO)/10); 

LH1:=SUM(IF(C1>=(HI/GZ),V,0),DA);

LH2:=SUM(IF(C1>=(HI/POW(GZ,2)) AND C1<(HI/GZ),V,0),DA);

LH3:=SUM(IF(C1>=(HI/POW(GZ,3)) AND C1<(HI/POW(GZ,2)),V,0),DA);

LH4:=SUM(IF(C1>=(HI/POW(GZ,4)) AND C1<(HI/POW(GZ,3)),V,0),DA);

LH5:=SUM(IF(C1>=(HI/POW(GZ,5)) AND C1<(HI/POW(GZ,4)),V,0),DA);

LH6:=SUM(IF(C1>=(HI/POW(GZ,6)) AND C1<(HI/POW(GZ,5)),V,0),DA);

LH7:=SUM(IF(C1>=(HI/POW(GZ,7)) AND C1<(HI/POW(GZ,6)),V,0),DA);

LH8:=SUM(IF(C1>=(HI/POW(GZ,8)) AND C1<(HI/POW(GZ,7)),V,0),DA);

LH9:=SUM(IF(C1>=(LO*GZ) AND C1<LO*POW(GZ,2),V,0),DA);

LH10:=SUM(IF(C1>=LO AND C1<LO*GZ,V,0),DA);

L1:=REFDATE(HHV(LH1,DA),DATE);

L2:=REFDATE(HHV(LH2,DA),DATE);

L3:=REFDATE(HHV(LH3,DA),DATE);

L4:=REFDATE(HHV(LH4,DA),DATE);

L5:=REFDATE(HHV(LH5,DA),DATE);

L6:=REFDATE(HHV(LH6,DA),DATE);

L7:=REFDATE(HHV(LH7,DA),DATE);

L8:=REFDATE(HHV(LH8,DA),DATE);

L9:=REFDATE(HHV(LH9,DA),DATE);

L10:=REFDATE(HHV(LH10,DA),DATE);

SS:=(L1+L2+L3+L4+L5+L6+L7+L8+L9+L10);

STICKLINE(CEILING(DA*L1/SS)*3>=CURRBARSCOUNT,HI*99/100,HI/GZ,9,0),

,COLOR002288,LINETHICK3;

STICKLINE(CEILING(DA*L2/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,1)*99/100

,HI/POW(GZ,2),9,0),COLOR800600,LINETHICK3;

STICKLINE(CEILING(DA*L3/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,2)*99/100

,HI/POW(GZ,3),9,0),COLOR808300,LINETHICK3;

STICKLINE(CEILING(DA*L4/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,3)*99/100

,HI/POW(GZ,4),9,0),COLOR883D88,LINETHICK3;

STICKLINE(CEILING(DA*L5/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,4)*99/100

,HI/POW(GZ,5),9,0),COLOR777700,LINETHICK3;

STICKLINE(CEILING(DA*L6/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,5)*99/100

,HI/POW(GZ,6),9,0),COLOR804000,LINETHICK3;

STICKLINE(CEILING(DA*L7/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,6)*99/100

,HI/POW(GZ,7),9,0),COLOR003377,LINETHICK3;

STICKLINE(CEILING(DA*L8/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,2),LO*POW(GZ,3)

*99/100,9,0),COLORLICYAN,LINETHICK3;

STICKLINE(CEILING(DA*L9/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,1),LO*POW(GZ,2)

*99/100,9,0),COLORLIMAGENTA,LINETHICK3;

STICKLINE(CEILING(DA*L10/SS)*3>=CURRBARSCOUNT,LO,LO*POW(GZ,1)*99/100,9,0)

,COLORBROWN,LINETHICK3;

DRAWKLINE(H,O,L,C);


版权声明

本文版权归掌上指标所有。
未经许可,不得转载,转载请注明出处!

服务热线

18020657357

微信客服

微信客服