【通达信源码分享】精品指标公式-暴涨牛

通达信免费指标 07-26 阅读:388 评论:0

HJ_1:=5;

 HJ_2:=10;

 HJ_3:=REF(CLOSE,1);

 HJ_4:=(2*CLOSE+HIGH+LOW)/4;

 HJ_5:=MA(HJ_4,3)>REF(MA(HJ_4,3),1);

安全线:2,POINTDOT,COLORRED,LINETHICK4;

 HJ_6:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*10;

 K:MA(3*SMA(HJ_6,6,1)-2*SMA(SMA(HJ_6,5,1),5,1),3),COLORF00FF0;

 D:MA(K,3),COLORBLUE;

 J:3*K-2*D,COLORF00FF0;

 DRAWBAND(K,RGB(155,50,50),D,RGB(0,100,50));

 HJ_7:=CLOSE-REF(CLOSE,1);

 HJ_8:=100*EMA(EMA(HJ_7,6),6)/EMA(EMA(ABS(HJ_7),6),6);

 HJ_9:=EMA(CLOSE,5);

 HJ_10:=EMA(CLOSE,13);

 HJ_11:=DRAWLINE(LOW=LLV(LOW,BARSLAST(CROSS(HJ_10,HJ_9))+1),LLV(LOW,BARSLAST(CROSS(HJ_10,HJ_9))+1),HIGH=HHV(HIGH,BARSLAST(CROSS(HJ_9,HJ_10))+1),HHV(HIGH,BARSLAST(CROSS(HJ_9,HJ_10))+1),0);

 HJ_12:=DRAWLINE(HIGH=HHV(HIGH,BARSLAST(CROSS(HJ_9,HJ_10))+1),HHV(HIGH,BARSLAST(CROSS(HJ_9,HJ_10))+1),LOW=LLV(LOW,BARSLAST(CROSS(HJ_10,HJ_9))+1),LLV(LOW,BARSLAST(CROSS(HJ_10,HJ_9))+1),0);

 BT:LLV(HJ_8,2)=LLV(HJ_8,7) AND COUNT(HJ_8<0,2) AND CROSS(HJ_8,MA(HJ_8,2)) AND REF(HJ_12,1)<REF(HJ_12,2) AND HJ_11>REF(HJ_12,1);

底线:0,COLORMAGENTA;

顶线:10,COLORBLUE;

 STICKLINE(HJ_11,0,0.2,3,0),COLORRED;

 STICKLINE(HJ_12,0,0.2,3,0),COLORGREEN;

 STICKLINE(BT,0,3,2,0),COLOR000088;

 STICKLINE(BT,0,3,1,0),COLOR0000CC;

 STICKLINE(BT,0,3,0.22,0),COLORRED;

 DRAWTEXT(BT,3,57),COLORRED;

 TJ1:REF(HJ_12,1)<REF(HJ_12,2) AND HJ_11>REF(HJ_12,1) AND CLOSE<HHV(HIGH,21)*0.82;

 STICKLINE(TJ1,0,2,3,0),COLOR880088;

 STICKLINE(TJ1,0,2,1.5,0),COLORAA00AA;

 STICKLINE(TJ1,0,2,0.8,0),COLORCC00CC;

 STICKLINE(TJ1,0,2,0.2,0),COLORMAGENTA;

 DRAWTEXT(TJ1,2,58),COLORMAGENTA;

 HJ_13:=HHV(HIGH,55);

 HJ_14:=LLV(LOW,55);

 HJ_15:=HJ_13*HJ_14;

 HJ_16:=SQRT(HJ_15);

 TJ2:REF(HJ_12,1)<REF(HJ_12,2) AND HJ_11>REF(HJ_12,1) AND CLOSE<HJ_16;

 STICKLINE(TJ2,0,1,5,0),COLOR008888;

 STICKLINE(TJ2,0,1,2,0),COLOR00AAAA;

 STICKLINE(TJ2,0,1,1,0),COLOR00CCCC;

 STICKLINE(TJ2,0,1,0.2,0),COLORYELLOW;

 DRAWTEXT(TJ2,1,59),COLORYELLOW;

 HJ_17:=REF(HJ_11,1)>REF(HJ_11,2) AND HJ_12<REF(HJ_11,1);

 STICKLINE(HJ_17,10,9,5,0),COLOR008800;

 STICKLINE(HJ_17,10,9,2,0),COLOR00AA00;

 STICKLINE(HJ_17,10,9,1,0),COLOR00CC00;

 STICKLINE(HJ_17,10,9,0.2,0),COLORGREEN;

 DRAWTEXT(HJ_17,9,4),COLORGREEN;

 DIFF:EMA(DCLOSE,12)-EMA(DCLOSE,26);

 DEA:EMA(DIFF,9),COLORCYAN;

 HJ_18:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:REF(CLOSE,HJ_18+1)>CLOSE AND DIFF>REF(DIFF,HJ_18+1) AND CROSS(DIFF,DEA);

 DRAWTEXT(底背离,(-0.6),60),COLORWHITE;

 HJ_19:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:REF(CLOSE,HJ_19+1)<CLOSE AND REF(DIFF,HJ_19+1)>DIFF AND CROSS(DEA,DIFF);

 DRAWTEXT(顶背离,11,61),COLORWHITE;

买入:ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3),COLORRED;

卖出:ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3),COLORGREEN;

微信截图_20230726222050.png

版权声明

本文版权归掌上指标所有。
未经许可,不得转载,转载请注明出处!

服务热线

18020657357

微信客服

微信客服