【通达信源码分享】精品指标公式-我的主图筹码源码

通达信免费指标 04-09 阅读:436 评论:0

公式源码:


 


DRAWGBK(C>0,RGB(0,150,150),RGB(0,00,100),0,' ',0),LINETHICK2;


DRAWBAND(MA(COST(90),10),RGB(0,40,0),L,RGB(50,0,0));


DRAWKLINE(H,O,L,C);


{均线}


牛熊线:MA(COST(90),10),LINETHICK2;


 


DRAWTEXT_FIX(ISLASTBAR,0,0.02,0,STRCAT('地域:     ',DYBLOCK)),COLORYELLOW;


DRAWTEXT_FIX(ISLASTBAR,0.3,0.02,0,STRCAT('行    业:     ',HYBLOCK)),COLORYELLOW;


DRAWTEXT_FIX(ISLASTBAR,0,0.12,0,STRCAT('概    念:     ',GNBLOCK)),COLORRED; 


称帝:(COST(99)+COST(93)+COST(85))/3,COLORYELLOW,LINETHICK2;


IF(称帝>=REF(称帝,1),称帝,DRAWNULL),COLORYELLOW,LINETHICK2; 


IF(称帝< REF(称帝,1),称帝,DRAWNULL),COLORBLUE,LINETHICK2; 


 


X:=(3*C+L+O+H)/6;


多空线:(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)


+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)


+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+


REF(X,20))/210,COLORGREEN,LINETHICK2;


IF(多空线>=REF(多空线,1),多空线,DRAWNULL),COLORRED,LINETHICK2; 


IF(多空线< REF(多空线,1),多空线,DRAWNULL),COLORGREEN,LINETHICK2;


DRAWICON(CROSS( C ,多空线), C ,25),LINETHICK2;


DRAWTEXT(CROSS(C,多空线),LOW,'★低吸 '),COLORFFFFFF; 


V0:=多空线,COLOR00FF66;


V1:称帝,COLOR00FF66;


LC1:=REF(CLOSE,1);


RSI:=SMA(MAX(CLOSE-LC1,0),6,1)/SMA(ABS(CLOSE-LC1),6,1)*100; 


DRAWTEXT(CROSS(RSI,11),LOW,'★低吸 '),COLORFFFFFF;


{涨停}


STICKLINE(C>REF(C,1)*1.098,O,C,3,0),COLORRED;


{准备买入}


LC:=REF(CLOSE,1);


RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);


TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);


HD:=(HIGH - REF(HIGH,1));


LD:=(REF(LOW,1) - LOW);


DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);


DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);


PDI:=((DMP * 100) / TR1);


MDI:=((DMM * 100) / TR1);


ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);


AV:=(RSI5 + ADX);


WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));


NEWVOL:=(RSI5 - WR10);


赚钱:=(AV + NEWVOL);


STICKLINE(赚钱<5,H,L,0,0),COLOR008000;{买点预警}


STICKLINE(赚钱<5,O,C,3,0),COLOR008000;


STICKLINE(CROSS("MACD脉冲.脉冲",0.4),H,L,0,0),COLORBLUE;


STICKLINE(CROSS("MACD脉冲.脉冲",0.4),O,C,3,0),COLORBLUE;


 


趋界:=100*(LOW/MA(C,10))-100 ;


L抄底:=(LOW-DMA((3*HIGH+LOW+OPEN+2*LOW)/7,VOL/(SUM(AMOUNT,10)/(AMOUNT/VOL/7)/7)))/DMA((3*HIGH+LOW+OPEN+2*LOW)/7,VOL/(SUM(AMOUNT,10)/(AMOUNT/VOL/7)/7))*100;


H抄底:=(H-DMA(((3*HIGH+LOW+OPEN+2*H)/7),VOL/(SUM(AMOUNT,10)/(AMOUNT/VOL/7)/7)))/DMA(((3*HIGH+LOW+OPEN+2*H)/7),VOL/(SUM(AMOUNT,10)/(AMOUNT/VOL/7)/7))*100;


C抄底:=(CLOSE-DMA(((3*HIGH+LOW+OPEN+2*CLOSE)/7),VOL/(SUM(AMOUNT,10)/(AMOUNT/VOL/7)/7)))/DMA(((3*HIGH+LOW+OPEN+2*CLOSE)/7),VOL/(SUM(AMOUNT,10)/(AMOUNT/VOL/7)/7))*100;


抄底:=(L抄底+H抄底+C抄底)/3;


L短线:=IF(((MA(((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100)-LLV((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100),10)),2)*3+((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100)-LLV((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100),10))*13)/16)>13,MA(((MA(((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100)-LLV((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100),10)),2)*3+((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100)-LLV((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100),10))*13)/16),2),((MA(((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100)-LLV((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100),10)),2)*3+((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100)-LLV((SMA(MAX(L-REF(L,1),0),5,1)/SMA(ABS(L-REF(L,1)),5,1)*100),10))*13)/16));


H短线:=IF(((MA(((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100)-LLV((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100),10)),2)*3+((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100)-LLV((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100),10))*13)/16)>13,MA(((MA(((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100)-LLV((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100),10)),2)*3+((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100)-LLV((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100),10))*13)/16),2),((MA(((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100)-LLV((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100),10)),2)*3+((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100)-LLV((SMA(MAX(H-REF(H,1),0),5,1)/SMA(ABS(H-REF(H,1)),5,1)*100),10))*13)/16));


C短线:=IF(((MA(((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100)-LLV((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100),10)),2)*3+((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100)-LLV((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100),10))*13)/16)>13,MA(((MA(((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100)-LLV((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100),10)),2)*3+((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100)-LLV((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100),10))*13)/16),2),((MA(((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100)-LLV((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100),10)),2)*3+((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100)-LLV((SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100),10))*13)/16));


短线:=(L短线+H短线+C短线)/3 ;


短买:=(L-REF(C,10))-MA((L-REF(C,10)),5) ;


J:= 3*SMA(((C-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100),3,1)-2*SMA(SMA(((C-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100),3,1),3,1) ;


LJ:=3*SMA(((L-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100),3,1)-2*SMA(SMA(((L-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100),3,1),3,1) ;


CD:=短买<0 AND 抄底<=-2 AND  LJ<2  AND ((L短线=0 AND L抄底<=-2 ) AND (H短线<0.5 AND H抄底<=-1))  AND (100*(L-LLV(L,3))/(HHV(L,3)-LLV(L,3))=0 AND 100*(L-LLV(L,5))/(HHV(L,5)-LLV(L,5))=0  );


DD:=短线<4.2  AND (L短线<1 OR H短线<1 OR C短线<1) AND L短线<2 AND 抄底<-0.9  AND L抄底<-1.99  AND H抄底<7.2  AND 趋界<-1.5  AND  J<45;


可以抄底:=DD AND CD;


STICKLINE(可以抄底,H,L,0,0),COLORYELLOW;


STICKLINE(可以抄底,O,C,2,0),COLORYELLOW;


VAR1T:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);


VAR1F:=SMA(CROSS(赚钱,0),3,1);


VAR2F:=SMA(VAR1F,3,1);


VAR3F:=SMA(VAR2F,3,1);


DRAWICON(CROSS(赚钱,0) OR CROSS(VAR1T,8),L,1);


DRAWICON(CROSS(VAR2F,VAR3F) AND (VAR2F<40),L,41);


{角买}


MTM:=C-REF(C,1);


DXD:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);


买:=LLV(DXD,2)=LLV(DXD,7) AND COUNT(DXD<0,2) AND CROSS(DXD,MA(DXD,2));


STICKLINE(FILTER(买=1,5),H,L,0,0),COLORMAGENTA;


STICKLINE(FILTER(买=1,5),C,O,3,0),COLORMAGENTA;


{白柱子买点}


HLCO:=(C+H+L+O)/4;


MAHC:=MA((CLOSE*2+H)/3,5),COLOR0000FF;


MAHO:=MA((O*2+H)/3,5),COLOR00FF00;


MALO:=MA((O+L*2)/3,5),COLOR00FFFF;


CO1:=O+(C-O)/2;


STICKLINE(MAHC<MAHO AND (CROSS(C,MALO) OR CROSS(HLCO,MALO)),CO1,MIN(C,O),1.5,0),COLORWHITE;


{暴涨}


ZF:=(C/REF(C,1)-1)*100;


AAAB:=SUM(ZF,3); 


DRAWICON(COUNT(AAAB<-6,3)=2 AND CROSS(AAAB,-6),L-0.1,11);

30-1G023214040.png

版权声明

本文版权归掌上指标所有。
未经许可,不得转载,转载请注明出处!

服务热线

18020657357

微信客服

微信客服