【通达信源码分享】牛暴涨,低了就买过了就卖(主图 源码 测试图)有未来函数

不确定线:=MA(CLOSE,15);
固定线:MA(CLOSE,43),LINETHICK2,COLORYELLOW;
DRAWTEXT(ISLASTBAR,固定线,STRCAT('低了就买:',CON2STR(固定线,2))),COLORYELLOW;
操作:=MA(C,3);
K线分界:HHV(操作,15),LINETHICK1,COLORRED,DOTLINE;
DRAWTEXT(ISLASTBAR,K线分界,STRCAT('K线分界:',CON2STR(K线分界,2))),COLORRED;
A1:=REF(HIGH,5)=HHV(HIGH,2*6+1);
B1:=FILTER(A1,5);
C1:=BACKSET(B1,5+1);
D1:=FILTER(C1,5+1);
A2:=REF(LOW,5)=LLV(LOW,2*10+1);
B2:=FILTER(A2,5+1);
C2:=BACKSET(B2,5+1);
D2:=FILTER(C2,5);
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
E2:=(HIGH+LOW)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
L1:=(D2 AND NOT(D1 AND E1<E2));
H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1;
WWW7:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);
J1:=BACKSET(BARSTATUS=2 ,MIN(BARSLAST(HD),BARSLAST(LD))+1);
J2:=J1>REF(J1,1);
C点:=BARSLAST(LD);
DRAWTEXT(LD AND BARSLAST(HD)<BARSLAST(REF(LD,1)) ,L-0.1,'A'),COLORRED;
DRAWTEXT(LD AND BARSLAST(HD)<BARSLAST(REF(LD,1)) ,L-0.04,'A'),COLORYELLOW;
DRAWTEXT(HD,H+0.1,'B'),COLORGREEN;
DRAWTEXT(HD,H+0.04,'B'),COLORWHITE;
HARB:=EMA(EMA(EMA(CLOSE,5),5),5);
HARX:=(HARB-REF(HARB,1))/REF(HARB,1)*100;
DRAWTEXT(CROSS(HARB,HARX),REF(H,1),'傻卖'),COLORGREEN;
DRAWTEXT(CROSS(HARX,0),REF(L,1),'傻买'),COLORYELLOW;
NE:=IF(NAMELIKE('S') OR NAMELIKE('*S'),0.05,0.1);
ZT:=C/REF(C,1)-1>=NE-0.01/REF(C,1) AND C=H AND PERIOD=5;
ZX:=O+((C-O)*0.618);
XJ:=DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3),HHV(HIGH,3),1),LINETHICK2;
XG:=ZT AND C>XJ AND ZX>XJ ;
HBQQ:=FILTER(XG,3);
周M:="MACD.MACD#WEEK";
月M:="MACD.MACD#MONTH";
年M:="MACD.MACD#YEAR";
日M:=MACD.MACD;
HB1:= HBQQ AND 周M>0 AND 月M>0 AND 年M>0  AND 日M>0 ;
T:=O>REF(H,1) AND L>REF(H,1) AND C>=O AND HBQQ;
STICKLINE(HBQQ AND T,L-0.35,L-0.67,2,0),COLORYELLOW;
STICKLINE(HBQQ AND T,L-0.35,L-0.67,0,0),COLORBLACK;
DRAWICON(HBQQ AND T,L-0.56,18);
DRAWTEXT(HBQQ AND T,L-0.57,'吃大肉');
最小值:=LLV(LOW,10);
最大值:=HHV(HIGH,25);
波动线:=EMA((CLOSE-最小值)/(最大值-最小值)*4,4);
平均线:=EMA(波动线,3);
信息:=平均线>=REF(平均线,1);
走弱:=CLOSE<MA(CLOSE,10)AND CLOSE<MA(CLOSE,5);
TZ:=(信息=0 AND REF(信息,1)=1) AND (REF(信息,2)+REF(信息,3)=2)  AND 走弱=1 AND 平均线>1;
DRAWTEXT(TZ=1,H+0.095,'下走确认'),COLORRED;
MA13:=MA(C,13);
MA34:=MA(C,34);
MA55:=MA(C,55);
VAR1RR:=(100-((90*(HHV(HIGH,21)-CLOSE))/
(HHV(HIGH,21)-LLV(LOW,21))));
VAR2RR:=(100-((90*(HHV(HIGH,21)-CLOSE))/
(HHV(HIGH,21)-LLV(LOW,21))));
VAR3RR:=(100-MA(((100*(HHV(HIGH,6)-CLOSE))/
(HHV(HIGH,6)-LLV(LOW,6))),34));
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
低吸:=CROSS(RSI,11);
TZRR:=C/REF(C,1)>1.095 AND C=H;
VAR7RR:=EMA(AMOUNT/VOL/100,3);
VAR8RR:=EMA(VAR7RR,88);
VAR9RR:=EMA(VAR7RR,88)*0.85;
VARARR:=VAR9RR*0.87;
JX:=CROSS(C,MA(C,5)) AND CROSS(C,MA(C,10)) AND MA(C,5)<MA(C,10);
JX2:=SUM(OSC.MAOSC,15)/15<60;
JX3:=EVERY(MA(C,20)>REF(MA(C,20),1),10);
VARFRR:=(2*CLOSE+HIGH+LOW)/4;
VA4:=LLV(LOW,34);
VA5:=HHV(HIGH,34);
VA6:=EMA((VARFRR-VA4)/(VA5-VA4)*100,6);
VA7:=EMA(0.667*REF(VA6,1)+0.333*VA6,4);
TJ:=CROSS(OSC.OSC,OSC.MAOSC) AND OSC.MAOSC>30;
TJA:=DMI.ADXR>DMI.ADX AND DMI.ADX>30;
TJ1:=(EVERY(VA7>VAR3RR,10) AND EVERY(VAR2RR>VAR3RR,10) AND CROSS(VAR2RR,VA7) AND TJ AND TJA);
XXB:=FILTER(COUNT(TJ1,32)>0 AND TZRR,20) AND REF(C,1)/REF(C,2)<1;
STICKLINE(XXB,H+0.35,L-0.45,0.1,0),COLORFF0966;
DRAWTEXT(XXB,L-0.05,'更上一层楼'),COLORFF0966;
ZK1:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),DOTLINE,COLORGREEN,LINETHICK2;
DRAWTEXT(ISLASTBAR,ZK1,STRCAT('过了就卖:',CON2STR(ZK1,2))),COLORGREEN;
ZD1:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK2,COLORRED;
ZD2:=EMA(ZD1,25),LINETHICK2;
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:=((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,10000,10000),COLOR00AAAA,LINETHICK;
V2:=SMA(IF(C>=REF(C,1),DDX,-DDX/100),2,1);
V5:=SMA(V2*120/FROMOPEN*5,2,1);
V10:=SMA(V5,5,1);
V20:=SMA(V10,5,1);
DY:=CURRBARSCOUNT=1 AND C<REF(C,1);
DY2:=REF(V2,1)-DY;
XG2:=C>O AND DY2<0.02 AND MA(C,5)>MA(C,60) AND C/REF(C,1)>=1.02 AND H<ZK1;
DRAWTEXT(XG2 AND L<ZD1,L,'↖牛暴张'),COLORRED;

 


服务热线

18020657357

微信客服

微信客服