【通达信免费源码】能量成交提示买卖幅图公式 说明 源码

【通达信免费源码】能量成交提示买卖幅图公式 说明 源码

量能成交量公式是把大家最常用的成交量指标和改进的量能潮指标结合起来,不需要另外增加副图栏占用版面,使用起来非常方便.
使用方法:当成交量中第一次出现黄色量能柱时为买入点, 黄色量能柱持续期间持股. 当成交量中第一次失去黄色量能柱时为卖出点, 无黄色量能柱期间空仓.

公式源码:

TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,1)))));

MTIME:=MOD(FROMOPEN,TOTAL);

CTIME:=IF(MTIME<0.5,TOTAL,MTIME);

VVOL:IF(CURRBARSCOUNT=1,VOL*TOTAL/CTIME,DRAWNULL),NODRAW;

STICKLINE(CURRBARSCOUNT=1 && (SETCODE=0 || SETCODE=1),VVOL,0,-1,-1),COLOR00C0C0;

VOLUME:VOL,VOLSTICK;

MAVOL1:MA(VOLUME,5);

MAVOL2:MA(VOLUME,10);

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);

OBV2:=EMA(OBV1,3)-MA(OBV1,9);

OBV3:=EMA(IF(OBV2>0,OBV2,0),3);

MAC3:=MA(C,3);

STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,OBV3,1,0),COLORYELLOW;


联系客服