【通达信免费源码】主图画线指标 主图 画线 操盘控盘

30-1P524214156.png30-1P524214157.png

N1:=20;

N2:=10;

N3:=5;

AA:=REF(H,N1)=HHV(H,2*N1+1);

QY:=BACKSET(AA,N1+1);

CC:=FILTER(QY,N1) AND H=HHV(H,N1+1);

DDD:=BARSLAST(CC);

GDTS:=IF(CC,CURRBARSCOUNT,0);

DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}

DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);

DINGBU1:=REF(DINGBU,DDD+1);

GDCS1:=CONST(DINGBUTS);

DINGBUTS1:=REF(DINGBUTS,DDD+1);

GDCS2:=CONST(DINGBUTS1);

DINGBU2:=REF(DINGBU1,DDD+1);

MM:=IF(CURRBARSCOUNT>GDCS2,0,1);

{DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,POINTDOT,LINETHICK2;

DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,POINTDOT,LINETHICK2;}

AA1:=REF(L,N1)=LLV(L,2*N1+1);

QY1:=BACKSET(AA1,N1+1);

CC1:=FILTER(QY1,N1) AND L=LLV(L,N1+1);

DD1:=BARSLAST(CC1);

DDTS:=IF(CC1,CURRBARSCOUNT,0);

YDB:=IF(DD1,REF(L,DD1),L);

DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);

DDCS1:=CONST(DDTS1);

ZDB:=REF(YDB,DD1+1);

DDTS2:=REF(DDTS1,DD1+1);

DDCS2:=CONST(DDTS2);

{DRAWLINE(CURRBARSCOUNT=DDCS2,L,ISLASTBAR,REF(L,DDCS2-1),1),COLOR0055FF,POINTDOT,LINETHICK2;

DRAWLINE(CURRBARSCOUNT=DDCS1,L,ISLASTBAR,REF(L,DDCS1-1),1),COLORYELLOW,POINTDOT,LINETHICK2;}

LAA:=REF(H,N2)=HHV(H,2*N2+1);

LQY:=BACKSET(LAA,N2+1);

LCC:=FILTER(LQY,N2) AND H=HHV(H,N2+1);

LDDD:=BARSLAST(LCC);

LGDTS:=IF(LCC,CURRBARSCOUNT,0);

LDINGBU:=IF(LDDD,REF(H,LDDD),H);{顶部}

LDINGBUTS:=IF(LDDD,REF(LGDTS,LDDD),LGDTS);

LDINGBU1:=REF(LDINGBU,LDDD+1);

LGDCS1:=CONST(LDINGBUTS);

LDINGBUTS1:=REF(LDINGBUTS,LDDD+1);

LGDCS2:=CONST(LDINGBUTS1);

LDINGBU2:=REF(LDINGBU1,LDDD+1);

LMM:=IF(CURRBARSCOUNT>LGDCS2,0,1);

{DRAWLINE(CURRBARSCOUNT=LGDCS2,H,ISLASTBAR,REF(H,LGDCS2-1),1),COLOR0055FF,POINTDOT;

DRAWLINE(CURRBARSCOUNT=LGDCS1,H,ISLASTBAR,REF(H,LGDCS1-1),1),COLORYELLOW,POINTDOT;}

LAA1:=REF(L,N2)=LLV(L,2*N2+1);

LQY1:=BACKSET(LAA1,N2+1);

LCC1:=FILTER(LQY1,N2) AND L=LLV(L,N2+1);

LDD1:=BARSLAST(LCC1);

LDDTS:=IF(LCC1,CURRBARSCOUNT,0);

LYDB:=IF(LDD1,REF(L,LDD1),L);

LDDTS1:=IF(LDD1,REF(LDDTS,LDD1),LDDTS);

LDDCS1:=CONST(LDDTS1);

LZDB:=REF(LYDB,LDD1+1);

LDDTS2:=REF(LDDTS1,DD1+1);

LDDCS2:=CONST(LDDTS2);

DDYL2:=DRAWLINE(CURRBARSCOUNT=LGDCS2,H,CURRBARSCOUNT=LGDCS1,H,1) COLORWHITE;

DDZC2:=DRAWLINE(CURRBARSCOUNT=LDDCS2,L,CURRBARSCOUNT=LDDCS1,L,1) COLORWHITE;

ZGSTAR:=(DDYL2+DDZC2)/2;

ZGEND:=CONST((DDYL2+DDZC2)/2);

STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);

LLAA:=REF(H,N3)=HHV(H,2*N3+1);

LLQY:=BACKSET(LLAA,N3+1);

LLCC:=FILTER(LLQY,N3) AND H=HHV(H,N3+1);

LLDDD:=BARSLAST(LLCC);

LLGDTS:=IF(LLCC,CURRBARSCOUNT,0);

LLDINGBU:=IF(LLDDD,REF(H,LLDDD),H);{顶部}

LLDINGBUTS:=IF(LLDDD,REF(LLGDTS,LLDDD),LLGDTS);

LLDINGBU1:=REF(LLDINGBU,LLDDD+1);

LLGDCS1:=CONST(LLDINGBUTS);

LLDINGBUTS1:=REF(LLDINGBUTS,LLDDD+1);

LLGDCS2:=CONST(LLDINGBUTS1);

LLDINGBU2:=REF(LLDINGBU1,LLDDD+1);

LLMM:=IF(CURRBARSCOUNT>LGDCS2,0,1);

{DRAWLINE(CURRBARSCOUNT=LLGDCS2,H,ISLASTBAR,REF(H,LLGDCS2-1),1),COLOR0055FF,POINTDOT;

DRAWLINE(CURRBARSCOUNT=LLGDCS1,H,ISLASTBAR,REF(H,LLGDCS1-1),1),COLORYELLOW,POINTDOT;}


服务热线

18020657357

微信客服

微信客服