【通达信免费源码】寻庄MCD指标副图 MACD指标 操盘控盘

30-1Q223193A9.png30-1Q223193A9-50.png

| 指标比系统macd反应要灵敏,用法说明,波段要看VDIF和VDEA在0轴上方运行还是在下方运行,同时关注二线与DDEA的关系。 |
| - |

公式源码:

STICKLINE(C>0,0,0,10,0),COLORWHITE;

均价:=(0.618(0.809C+0.191O)+0.382(IF(H=C,C,H)+IF(L=C,C,L))/2);

GZ:=(WMA(均价,1)0.618+(WMA(均价,3)+WMA(均价,5))/2+WMA(均价,8)0.382)/2;

N:=3;

LX:=(REF(GZ,2)+REF(GZ,1)+REF(GZ,0))/3;

AA:=(WMA(均价,34)0.618+(WMA(均价,55)+WMA(均价,89))/2+WMA(均价,144)0.382)/2;

FJX:=(REF(AA,2)+REF(AA,1)+REF(AA,0))/3;

LJ:=AMOUNT/(V*100);

XV:=(WMA(LJ,1)0.618+(WMA(LJ,3)+WMA(LJ,5))/2+WMA(LJ,8)0.382)/2;

ZJX:=(REF(XV,2)+REF(XV,1)+REF(XV,0))/3;

DV:=(WMA(LJ,34)0.618+(WMA(LJ,55)+WMA(LJ,89))/2+WMA(LJ,144)0.382)/2;

SMX:=(REF(DV,2)+REF(DV,1)+REF(DV,0))/3;

VIF:=(ZJX-SMX);

DIF:=(LX-FJX);

VDIF:((DIF+VIF))/2,COLOR6600FF,LINETHICK1;

VDEA:WMA(VDIF,N),LINETHICK1,COLORGREEN;

DDEA:WMA(VDIF,63);

MACD:5*(VDIF-VDEA),LINETHICK;

STICKLINE(MACD>0 AND VDIF<0,0,MACD,2,1),COLORBROWN;

STICKLINE(MACD>0 AND VDIF>0,0,MACD,2,0),COLORRED;

STICKLINE(MACD<0 AND VDIF<0,0,MACD,2,1),COLORCYAN;

STICKLINE(MACD<0 AND VDIF>0,0,MACD,2,0),COLORGRAY;


联系客服