B宝塔线副图,四色分别对应买卖持股和空仓(通达信公式 副图 源码 测试图)

通达信免费指标 01-17 阅读:391 评论:0
DRAWTEXT_FIX(ISLASTBAR,0.96,0.7,0,'白买入 '),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR,0.96,0.5,0,'红持股 '),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.96,0.3,0,'黄卖出 '),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.96,0.1,0,'绿空仓 '),COLORGREEN;
大大前收盘:=REF(C,4);
大前开盘:=大大前收盘;
大前收盘:=REF(C,3);
前开盘:=大前收盘;
前收盘:=REF(C,2);
昨开盘:=前收盘;
昨收盘:=REF(C,1);
今开盘:=昨收盘;
今收盘:=C;
4日最大:=MAX(MAX(MAX(今收盘,昨收盘),前收盘),大前收盘);
4日最小:=MIN(MIN(MIN(今收盘,昨收盘),前收盘),大前收盘); 
{分析家公式网 WWW.70822.COM}
止跌2K阴:=昨收盘=4日最小 AND 今收盘>昨收盘 AND 今收盘<=昨开盘;
STICKLINE(止跌2K阴,昨收盘,今收盘,3,0),COLORGREEN;
止跌2K阳:=昨收盘=4日最小 AND 今收盘>昨收盘 AND 今收盘>昨开盘;
STICKLINE(止跌2K阳,昨收盘,昨开盘,3,0),COLORWHITE;
STICKLINE(止跌2K阳,昨开盘,今收盘,3,0),COLORRED;
止跌3K阴:=前收盘=4日最小 AND 止跌2K阴 AND ((昨收盘<=前开盘 AND 今收盘<=昨开盘 AND 昨收盘>=前收盘 AND 今收盘>=昨收盘) OR 今收盘<=昨收盘);
STICKLINE(止跌3K阴,前收盘,今收盘,3,0),COLORGREEN;
止跌3K阳:=前收盘=4日最小 AND 昨收盘<=前开盘 AND 今收盘>昨开盘 ;
STICKLINE(止跌3K阳,前收盘,今开盘,3,0),COLORWHITE;
STICKLINE(止跌3K阳,今开盘,今收盘,3,0),COLORRED;
止涨2K阳:=昨收盘=4日最大 AND 今收盘<昨收盘 AND 今收盘>=昨开盘;
STICKLINE(止涨2K阳,昨收盘,今收盘,3,0),COLORRED;
止涨2K阴:=昨收盘=4日最大 AND 今收盘<昨收盘 AND 今收盘<昨开盘;
STICKLINE(止涨2K阴,昨收盘,昨开盘,3,0),COLORYELLOW;
STICKLINE(止涨2K阴,昨开盘,今收盘,3,0),COLORGREEN;
止涨3K阳:=前收盘=4日最大 AND 昨收盘<前收盘 AND 昨收盘>=前开盘 AND 今收盘>=昨开盘;
STICKLINE(止涨3K阳,前收盘,今收盘,3,0),COLORRED;
止涨3K阴:=前收盘=4日最大 AND 昨收盘<前收盘 AND 昨收盘>=前开盘 AND 今收盘<昨开盘 AND REF(止涨2K阳,1);
STICKLINE(止涨3K阴,前收盘,今开盘,3,0),COLORYELLOW;
STICKLINE(止涨3K阴,今开盘,今收盘,3,0),COLORGREEN;
止涨4K阳:=前收盘=4日最大 AND 前收盘<大前收盘 AND 昨收盘<前收盘 AND 昨收盘>=前开盘 AND 今收盘>=昨开盘;
STICKLINE(止涨4K阳,前收盘,今收盘,3,0),COLORRED;
止涨4K阴:=前收盘=4日最大 AND 前收盘<大前收盘 AND 昨收盘<前收盘 AND 昨收盘>=前开盘 AND 今收盘<昨开盘 AND REF(止涨2K阳,1);
STICKLINE(止涨4K阴,前收盘,今开盘,3,0),COLORYELLOW;
STICKLINE(止涨4K阴,今开盘,今收盘,3,0),COLORGREEN;
上涨:=(4日最大=今收盘 OR 今收盘>=昨开盘) AND IF(止跌2K阳=1,0,IF(止跌3K阳=1,0,1)) AND IF(REF(止跌2K阴,1)=1,0,IF(REF(止跌3K阴,1)=1,0,1)) ;
STICKLINE(上涨,今开盘,今收盘,3,0),COLORRED;{红色}
下跌:=(4日最小=今收盘 OR 今收盘<昨开盘) AND IF(止涨2K阴=1,0,IF(止涨3K阴=1,0,1)) AND IF(REF(止涨2K阳,1)=1,0,IF(REF(止涨3K阳,1)=1,0,1));

STICKLINE(下跌,今开盘,今收盘,3,0),COLORGREEN;



版权声明

本文版权归掌上指标所有。
未经许可,不得转载,转载请注明出处!

服务热线

18020657357

微信客服

微信客服